General discussion

Locked

Round Robin RIS

By Jon Pratt ·
Okay, so here?s my situation: I need to increase the available bandwidth for our RIS clients. We currently run a cisco chassis switch which allows us to have multiple Gb throughput to our servers and we're finding that for RIS a single gigabit NIC just isn't cutting it (I work for a school district and we often find ourselves imaging 200-500 machines simultaneously). No matter what I do I cannot seem to get round robin load balancing to work for RIS. I've tried using DHCP option 66 and specified a multiple IP host name but the clients only go to one IP/NIC(i've been unable to find PXE documentation granular enough to find out who resolves the hostname i.e. the DHCP server or the PXE client, although I suspect that it's the client but I'm not sure). I've confirmed that round robin works and I even tried turning off DNS caching on the DHCP server so that it wouldn't cache resolved IPs in case it was the DHCP server that resolves the hostname first before sending it to the PXE client. I've also tried running DHCP and RIS on the same box with the same result i.e. it directs all clients to the same IP/NIC for RIS (yes I authorized each IP). One thing that I did discover is that I can easily change the IP/NIC that a client uses. If I put only one host record in DNS for the RIS server, we'll call it ris1.domain.com, clients will then use the IP/NIC associated with ris1.domain.com. Interestingly when I add a new host record, we'll call it ris2.domain.com, pointing to another IP/NIC, it will ignore it and keep sending clients to the first address, but as soon as I delete the ris1.domain.com record it immediately finds ris2.domain.com and starts sending clients to that IP/NIC. My conclusion from this is that DNS is in fact being queried but for some reason the ability to use round robin is inactive?... Has anyone out there been able to get RIS to use multiple NICs simultaneously? I'd also be interested in any hardware solutions that might work. Thanks.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Jon Pratt In reply to Round Robin RIS

Point value changed by question poster.

Collapse -

by ross.bale In reply to Round Robin RIS

I can't answer the question in terms of round robin DNS, but can give an insight into how the PXE remote boot works which should help to locate the problem:

1. PXE Rom process requests IP Address from DHCP Server.
2. Client computer identifies itself as being PXE capable - indicates to any available RIS Server that it is looking to be serviced
3. Any available RIS Server can respond by providing the client with an IP Address and boot file that the client should request if required.
4. Client then requests bootstrap file from RIS Install via BINL

DHCP Port Info:
60 - Client Identifier - Set to "PXEClient"
66 - Boot Server Host Name
67 - Boot File name

this is not supported by microsoft and will stop RBFG generated clients from working - see Q259670

When you authorise a RIS Server via DHCP the name of the server specified during authorisation is entered rather than the IP Address - to authorise all adaptors, authorise each adaptor individually specifying the adaptor's IP Address rather than the server name, eg if the server has three lan adaptors - you need to authorise each one. Email me if you need more info.

Collapse -

by uwe In reply to Round Robin RIS

Hi there,
what Ross said is not completely correct (sorry mate ). When PXE boots it sends out a DHCP Discover with a line that is telling it to be PXE-capable. Both, DHCP and RIS-server (if they are on different machines) send an DHCP offer. PXE reqeuests the IP of the DHCP server. After that it sends another DHCP Request to the RIS-Server (sometimes after another DHCP Discover), after that the RIS sends information about boot filename and so on and then the TFTP-stuff goes on.

I think the best way todo load-balancing with RIS would be to do it over subnets: If you have several subnets, you could set up a server for each one (or a NIC) and set the ScopeOptions on the DHCP-Server. But be sure to unauthorize the RIS-DHCP then, because otherwise they would get their bootfile from there.

We had no other choice than doing it over the normal DHCP-Server here, cause RIS doesn't work in different subnets

Back to Windows Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums