Router cannot connect to the internet (via cable-modem)

By kronos ·
Hy everyone!

I searched this forum for some topics that are related to mine but couldn't solve the problem.

I connect to the internet with my PC via a Motorola SURFboard SB5100E. I obtain an IP address dynamically from my ISP and had to give my MAC-adresse to them. Everything works fine ... so far.

Now I want to connect the MN-700 as a router between my PC and my cable modem. I get perfect connection the the LAN and I'm able to copy the MAC-adresse of my former LAN-card. Now the MN-700 has my "old MAC" as new WAN-MAC and is switched to "dynamic connection".

Problem: the cable modem isn't able to get connection to the router. The MN-700 will not get a dynamic WAN-IP ... it is always saying "no connection" (also Modem-Lights are green).

I tryed to enter the "old" dynamic IP, DNS, ... as static WAN-IP. This works ... for about 5 minutes. Then the connection is gone and i need to reset both - cablemodem and router.

Would be fine if you can help me. I am out of ideas how to go on.


Cable-Modem => PC (dynamic IP) works
Broadband-Router (LAN) => PC (dynamic or static IP) works

Cable-Modem => Broadband-Router (WAN-port) doesnt work

Problem: Router isn't able to get a correct dynamic IP from modem

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -


by CG IT In reply to Router cannot connect to ...

clone your PC MAC address to your router so that the router now appears to be your PC.

Some ISPs filter connections via MAC address.

Collapse -

already tried this

by kronos In reply to clone

I already cloned the MAC-address and additionally asked my ISP to change their settings to the original MAC-address of the router.

No success so far.

Is it possible, that the different subnet-maskes (WAN: / LAN: cause this problem? I cannot change both - the first is assigned by the ISP and the second is not changeable.

Collapse -

If you cloned the MAC

by w2ktechman In reply to already tried this

and then had the ISP use the original MAC, you need to stop clonong it.
I am sure that you thought of that, but here is another suggestion
In your documentation for the Router, is there a way to do a factory reset on the router?

Collapse -

yes....different subnet masks make a difference

by CG IT In reply to already tried this

both the IP and the subnet mask comprise the whole address.

However your WAN link is dynamically assigned. So it doesn't matter as you can't assign a static # to the WAN link.

On the LAN side of things the router has it's own address. Most consumer level routers use Class C with the router address The subnet mask would be indicating 24 bits for the network and 8 bits for the host

Clients require the router address as their default gateway address and the ISPs DNS server addresses to be able to connect to the internet.

So a static assigned TCP/IP properties on a client would look like this;

ip address:
subnet mask:
default gateway [router address]
DNS servers: the ISP DNS server address [which should be those listed on the WAN status page or status page of the router or the ones the ISP told you to use.

Collapse -

That's how i did it

by kronos In reply to yes....different subnet m ...

So the WAN-net is class B and my LAN is class C.

You're right and there is no chance to change that. But is this really a problem?

You client TCP/IP properties are excactly like my ones.

I disabled DHCP for my LAN, so there is a fixed 192.168.0.xx (xx is 2-99) for the clients.

The problem is, that the router shows me, that it cannot connect to the modem. There must be some kind of inkompatibility between the SB5100 (Motorola) and my MN-700 (Microsoft).

I spoke with my ISP and they have no idea. As far as that people knew, i spoke to, their cable-servers are only MAC-specific and have no other security options or other preferences, which could interfere with my router.

I'm really out of ideas now...

Collapse -

wireless? or Wired

by CG IT In reply to That's how i did it

are you trying this on a wireless connection?

is the MS-700 preconfigured with Wireless security turned ON?

if so, then you need to provide the credentials and key to connect everything else being setup right. Even if the wireless utility says your connected. Some will show a connection but your not connected until you provide the credentials and key.

Collapse -

Deactivated WLAN

by kronos In reply to wireless? or Wired

For error-finding i deactivated every unused features (DHCP, WLAN, firewall)

I made it easier to explain my situation ...
check following picture:

Collapse -

Since your local LAN is working

by w2ktechman In reply to Deactivated WLAN

The Router will be blinking properly. How about the cable Modem, is the Link light on? Is the Data light on?
Try resetting the cable modem

If that still does not work, bypass the router and plug a computer in straight from the cable modem (old MAC)

If you are getting a connection to the Internet, turn the MAC cloning back on.
If you are not, then it may be the modem which is malfunctioning

Collapse -


by kronos In reply to Router cannot connect to ...

Long ago - but i feel like telling everyone having the same problem how i solved it:

Its a simple incompatibility between the Router and my internet provider. The cable-modem works with the router - tested with another cable-internet-provider.

In fact, the modem + old provider + another router worked too. So i had to buy another router (DLINK) and the problem was solved (dynamic IP, MAC-Adress-checking, ...)

Collapse -

Router Cannot Connect to the internet

by ashily24dee In reply to Router cannot connect to ...


Most of the problems related to router would be fixed by resetting. You have to switch off the modem power and after checking all the connections from the modem and to the modem, restart your computer. Check the modem configuration using the default IP address switch on your modem. Then try to connect with Internet using the user name and password which was given by your service provider.

Related Discussions

Related Forums