General discussion

Locked

Router problem

By CyberGod ·
How to describe a network which is behind the router so it can be visible from the Internet. How to do it if my router is CISCO or Linux server?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Router problem

by SteveD In reply to Router problem

Assuming you're using a private address space on your network and wish to do network address translation (NAT) to a public address supplied by your ISP, here are the basics, adapted from my Cisco router's configuration. I've used the fictional IP address 100.100.100.100 to represent the public address. The IP 192.168.0.1 is the router's address on the LAN. This is not a complete router configuration. These are just the parts that handle the NAT.

ip nat pool mypool 100.100.100.100 100.100.100.100 prefix-length 30
ip nat inside source list 1 pool mypool overload
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
ip nat inside
!
interface BRI0
ip address 100.100.100.100 255.255.255.252
ip access-group 111 in
ip nat outside

I hope this helps.

Steve Diamond

Collapse -

Router problem

by CyberGod In reply to Router problem

Poster rated this answer

Collapse -

Router problem

by schannachie In reply to Router problem

Hi,

In case of using linux boxes you have some solutions, of course are not simple things to do.

1.- Option (easy)Kernel 2.2x or higher level for Suse distribution i.e.

Download form www.boutell.com/rinetd

and install the package . It's a GPL software that redirects ports and ip addresses.

2.- Set ipfwadmin-wrapper (Very more complex)
all you need is at the info files and man pages.

3.- Set Suse firewall software and routing facilities.


4.- Set ipchains masquerading options (most dificult of all) this will act as a powerfull packet filter, NAT, and will allow you to reach your LAN and the internet on both sides. Info related at www.linux.org on ipchains and masquerading options. This will work fine in most linux kernels and the LAN will be protected with a user class firewall


For more info www.suse.com, firewall projects.


Good luck !

Collapse -

Router problem

by CyberGod In reply to Router problem

Poster rated this answer

Collapse -

Router problem

by zainalb In reply to Router problem

If you looking a linux solution try use this two product. E-smith (www.e-smith.org) or ClarkConnect (www.clarkconnect.org). This software easy to use ,install and only need low end of hardware to run. Go thier website for more info.

Collapse -

Router problem

by CyberGod In reply to Router problem

Poster rated this answer

Collapse -

Router problem

by CyberGod In reply to Router problem

This question was closed by the author

Back to Linux Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums