General discussion


RPC Disabled

By mrhillman ·
I have disabled my service called RPC. I need to get it back to normal, but the service will not let me back in. This is on a win2K system, stand alone. My original problem was an error telling me that I need print spooler service started in order to load drivers for my Lexmark printer. I tried to start the service and an error told me that I had a dependency error. I found that it was dependent on RPC so I was going to restart RPC (Disable and ReEnable). After disabling, I found that it will not let me into the area to ReEnable. It seems that I should be able to use a RUN command to change this. Any help would be greatly appreciated. The system has many problems with this service disabled. Thanks.

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Try Safe Mode or Recovery Console

by mrjay67 In reply to RPC Disabled

First things first...make sure you are logged in with administrator rights when working with svcs. Since you stopped one i will assume you were.

Unless you have logged in several times you might try the last known good option. Otherwise try usingsafe mode by pressing F8 when it prompts you at boot up. You might be able to restart services that way.
You can also try the recovery console. If its not an option at boot up you can choose it off of the Win2K CD. Just pop in CD and boot from it. There should be an option for recovery or installation. Choose the recovery option. In Recovery console you can start and stop services with a command such as: START RPC. At the console prompt you can type HELP to get a list of commands and how to use them.

In the future be careful when messing with services you're not sure of or dont know what they actually do. Especially RPC and any login or netstart svc. These svcs are vital to booting and loging in and can cause severe problems as you may have already noticed.

Hope this helps


Collapse -

RPC placed back in service

by mrhillman In reply to Try Safe Mode or Recovery ...

Thanks for the help. I used the console and typed help just as you suggested. The exact command to type (just FYI) is:
\WINNT>enable rpcss service_auto_start
Thanks Again....

Back to Desktop Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums