General discussion

Locked

RPM conflict

By cp409sd ·
I am trying to install the i386 version of gnome-libs on a machine that has the x86_64 version already. There are several packages that I have installed like this, but this one is presenting a problem. The problem looks like:

rpm -ivh gnome-libs-1.4.1.2.90-34.2.i386.rpm
Preparing... ############################## [100%]
file /etc/mime-magic.dat from install of gnome-libs-1.4.1.2.90-34.2 conflicts with file from package gnome-libs-1.4.1.2.90-34.2


I need to have BOTH versions installed for the requirements of an application that will be installed on this machine. I don't really know what to try in order to get around this, and have not found much help on the web. Thanks for any help you can provide.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Jaqui In reply to RPM conflict

rpm --force gnome-libs-1.4.1.2.90-34.2.i386.rpm

the -ivh isn't usually required.
it is most often used with srpm to extract the sources rather than install

Collapse -

by Nico Baggus In reply to RPM conflict

I am not sure you will get what you want.

Probably when you install this parts will
overwrite file of the otherone....
I would expect you need quite a different
package for i386 here one that has all path set
to the emulated environment.

--force will install the new files, probably
hust overwriting you 64bit files.

Kind regards,
Nico Baggus

Collapse -

by cp409sd In reply to

Thanks. It turns out that I didn't need to have these two concurrently installed. I was able to install the app. with just the x86_64 version. Thanks.

Collapse -

by cp409sd In reply to RPM conflict

This question was closed by the author

Back to Linux Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums