Question

Locked

Running Cisco VPN client on a wireless connection

By pnubull ·
Hi, I've a secured wireless connection using D-link router. When I run cisco VPN client,
it connects, but the internet connection is lost immediately (in 3 seconds). If I connect
ethernet cable, VPN and internet connection
works fine (no issue). NOTE: The "lost connection" happens for all wireless networks I tried (4 different places).

It appears there is some conflict between
wireless connection and Cisco VPN client connection. There should be some configuration
setting on wireless router or VPN client which should fix this issue, but can't figure it out.
I tried disabling PPTP and changing MTU sizes, but no luck.

Please help. Thanks very much.

Some info:
Windows XP Home SP2
Cisco VPN client 4.6.03.0021

This conversation is currently closed to new comments.

26 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

tried newer version of VPN client

by pnubull In reply to Running Cisco VPN client ...

I uninstalled 4.6 client and installed 4.8.02.0010, but gave the same issue.

I think the error is due to this log msg on vpn client:

3 20:04:02.828 03/05/07 Sev=Warning/3 CM/0xA3100027
Adapter address changed from 192.168.0.100. Current address(es): 192.168.239.82.

Any help is very much appreciated.

Thanks.

Collapse -

VPN client disconnection - not solved

by hisaroj In reply to tried newer version of VP ...

I have the same scenario what is being discussed in this forum. The only difference in log is:
"Adapter address changed from 192.168.1.100. Current address(es): 127.0.0.1."

I have tried with all suggestions given in this forum, but still getting the same error - reason:422 Lost contact with network...

I have Broadcom 802.11b/g WLAN Network Adapter
VLAN Priority Support - Disabled

If somebody can help, then it will be great.
Thanks in advance.

Collapse -

Installed VPN client 5.0

by kok004 In reply to Running Cisco VPN client ...

I had the same problem, the client connected but i lost ip connectivity. I have recently installed a Beta version of the Cisco VPN client version 5.0.00.0320 and this solved the problem for me.

Collapse -

Having same problem using ver. 5.0.00.0340

by jgreene In reply to Running Cisco VPN client ...

I have an established VPN connection from my home XP Pro box to work, but just as in this original post, I cannot access the internet while the VPN is connected. My home box has a wireless connection to the internet through a D-link router. One other post claimed that upgrading the cisco client to ver. 5.0.00.0320 solved their problem, but I'm using 5.0.00.0340, and I'm having the problem. I'm going to try hooking up an ethernet cable tonight, but does anyone have any ideas as to how to fix this problem, and if it is truly due to the wireless nature of the internet connection? Thanks.

Collapse -

Could be a Broadcom driver problem

by sknobloc In reply to Having same problem using ...

I had the same problem. I finally found out that Broadcom didn't exactly follow the standards on their wireless card (I have a HP NX9600). I ended up rolling back the driver to a 2003 version and it now works flawlessly. Hope this helps others out there.

Scott

Collapse -

Disable VLAN Priority Support-Worked for my users

by m.madden In reply to Could be a Broadcom drive ...

I have also been plagued by this exact issue for a year or more. Mainly as it resolved and reappeared with no reason and no definitive fix. I've had at least 20 users at my office experience this issue with no solutions to be found in internet searches.
The scenario is the same as most others here have described.
A user has a good connection to the internet via a wireless connection at home. They can successfully connect and authenticate to their company VPN via Cisco VPN client. But then no other traffic will flow (no internet, intranet, email icmp, etc). If they connect via wired connection everything works fine.

This does not affect everybody and usually only happens at home (works fine at a hotel or hotspot form the same system and same user).

I narrowed the issue down to a combination of Cisco VPN client, built in wireless LAN on Dell and HP laptops (both of which use a Broadcom chipset), and usually home wireless routers.
The thing I found most perplexing about this was that sometimes the problem would go away for several weeks. I mean all 20 users would all of a sudden start working again. We could not trace this occurrence to any patch event, etc.
Sometimes just installing the latest WLAN drivers from from Dell would resolve the issue. But then a few weeks later it would pop-up again.
I tried everything, updating router firmware, using different versions of WLAN adapter drivers, different Cisco VPN client versions, changing my WiFi security (WEP, WPA, WPA2, None) options, Still I never found a solution.

Anyway Dell finally did enough research and posted a solution, and only finalized it a week or two ago. Here is the link:

http://support.dell.com/support/topics/global.aspx/support/dsn/en/document?c=us&cs=RC956904&docid=152D7D67033477DFE0401E0A5517188F


**************
The fix is to disable VLAN Priority Support on the WLAN adapter.
**************
This worked for all my Dell users so far.
The HP WLAN driver doesn't have the option available, but its probably the same thing-still researching. So far the Broadcom chipset is the common denominator between the Dells and HP. And I think they make the chipsets for Linksys wireless routers as well. I was not able to gather enough information for those that had the issue to know all the routers that they had when they had problems, or even if it was only certain firmware versions.

Since this usually only happens at home, my guess is most home routers lack VLAN support and something between the Cisco client, the WLAN driver and the router WiFi support gets confused when a VLAN Priority request is sent or something like that. And since most hotspots/hotels will use a more commercial Wireless router, VLAN is more than likely supported and thus the problem is not encountered. Also the default VLAN priority option is default set to Auto, which may explain why the problem was intermittent.
Of course this is only a guess.

One of my users said their problem went away simply when they switched from cable to Fios-possible but I think probably a coincidence.

I hope this helps everybody out there.

Collapse -

Disabling VLAN Priority Support-Worked for our laptop

by bjarvis In reply to Disable VLAN Priority Sup ...

My wife received a laptop from her company a couple of weeks ago. Her laptop had all the symptoms you cited in your post. I tried everything I could: contacted her company helpdesk, contact our Linksys router tech support, adjusted MTUs, forwarded ports, adjusted IP addresses, tweaked VPN settings, adjusted peer response times, etc. Then, I saw your recent post. Turns out that my wife's laptop is an HP with that suspect Broadcom wireless adapter (version 4.40.19.0). I disabled VLAN Priority Support on the network card and... the laptop has been operating for 5 hours straight with no hiccups.

Thanks a lot for the information you provided!

Collapse -

Thank you. It worked

by ksatyagupta In reply to Disable VLAN Priority Sup ...

Hello,

I have been having this issue for the last 9 months. Me & my husband tried various different options but with no luck. Our Help Desk also couldnt offer support saying, this is home networking and since it works fine with a public wireless network, our job is done.
It was very very kind of you to post this here. My sincere thanks once again

Collapse -

Thank You, Solved My Problem

by joen In reply to Disable VLAN Priority Sup ...

I have been searching forums, Google etc.. for the past 2 weeks. When I saw your post I new that was it, I tried it and everything works fine. I will pass the info along to our Network Admin. Thank you very much.

Collapse -

Solved my problem too

by steven.humphries In reply to Thank You, Solved My Prob ...

My issue wasn't identical in that I could never even contact my gateway to input credentials when running over my home wireless network. I'm using a Dell D620 connecting to a TrendNet home wireless router.

However, once I disabled the VPN Priority (which was set to AUTO), I've had no problems since.

Thanks so much for taking the time to post and help others out!

Back to Networks Forum
26 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums