General discussion

Locked

Samba server configuration

By suryamanikar ·
I have been configured samba successfully. I am using linux as my server and all other 95 machines wants to share his resources.

I am seeing Linux in my windows explorer. but when I want to login it shows authentication failure. can please suggest me.


I am attaching the smb.conf files.


# Samba config file created using SWAT
# from jamuna.macmetit.com (128.209.24.77)
# Date: 2000/03/01 15:03:55

# Global parameters
[global]
workgroup = WG1
netbios name = LINUX
server string = Samba Server
log file = /var/log/samba/log.%m
max log size = 50
announce as = WfW
time server = Yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
domain logons = Yes
domain master = Yes

[homes]
comment = Home Directories
path = %H
valid users = %S
read only = No
create mask = 0600
directory mask = 0700
browseable = No
locking = No

[netlogon]
path = /home/netlogon
guest ok = Yes

[printers]
comment = All Printers
path = /var/spool/samba
guest ok = Yes

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Samba server configuration

by McKayTech In reply to Samba server configuratio ...

By default, SAMBA expects clear-text passwords and Win95 encrypts them. So you can either do a registry hack on the Win95 machines to send passwords in clear text, or you can configure SAMBA to expect encrypted.

You'll need to put this line in your smb.conf:
encrypt passwords = yes

Restart SAMBA after making this change.

Then use smbpasswd to create a Samba username.

Try logging on under that password - it should work.

paul

Collapse -

Samba server configuration

by suryamanikar In reply to Samba server configuratio ...

The question was auto-closed by TechRepublic

Collapse -

Samba server configuration

by andresen In reply to Samba server configuratio ...

You should check to make sure you have setup users in linux for the windows users. Then if windows 95 is version B or above the default is using encrypted passwords. follw the instructions in the last answer. If you add users after you run smbpasswdthe first time you need to add a -a in the line (smbpasswd -a username) this will add them to the password file without overwriting it.

Collapse -

Samba server configuration

by suryamanikar In reply to Samba server configuratio ...

The question was auto-closed by TechRepublic

Collapse -

Samba server configuration

by mike In reply to Samba server configuratio ...

Another way to solve problem - apply into Windows registry the "Win98_PlainPassword.reg" file which contain required string to using unencrypted passwords with Samba. In this case you can use Linux password file to authenticate users on Samba sharing.

Collapse -

Samba server configuration

by suryamanikar In reply to Samba server configuratio ...

The question was auto-closed by TechRepublic

Collapse -

Samba server configuration

by jwallen In reply to Samba server configuratio ...

you also don't have a 'security =' parameter in your
smb.conf file. i'll describe the main options for this parameter.

share - anyone who knows a valid password for the share will have acess

user - user must give their own password and that password must be in the smbpasswd file

server - same as user but the password file is located on a seperate server

domain-level - samba becomes a member of a windows domain and uses the primary domain controller for authentication. once a machine is authenticated the user gets a special token which allows her/him access to any user-accessable share.

with your favorite editor add one of these options into your /etc/smb.conf file and then restart samba with the following:

/etc/rc.d/init.d/smb restart

hope that helps.

jack wallen, jr.
editor in chief of Linux content
TechRepublic

Collapse -

Samba server configuration

by suryamanikar In reply to Samba server configuratio ...

The question was auto-closed by TechRepublic

Collapse -

Samba server configuration

by techcenter In reply to Samba server configuratio ...

If you are going to use "Domain Logons" then you must also set "security = user".
If your win95 clients are OSR2 or later, win98 then you must also use "encrypt passwords = yes".
Change "announce as=" to NT because you are acting as an NT domain when you provide logons.
The Win95 user must have a valid account on the linux box and then add a Samba account. (ex: $ smbadduser -a joe:joe)
Here are some recomended [Global] settings.
security = user
password level = 4
username level = 4
local master = yes
os level = 64
domain master = yes
preferred master = yes
domain logons = yes
logon script = logon.bat
preserve case = yes
short preserve case = no
default case = lower
case sensitive = no

Collapse -

Samba server configuration

by suryamanikar In reply to Samba server configuratio ...

The question was auto-closed by TechRepublic

Back to Linux Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums