Question

Locked

Sata drive inaccessible following RAID setup - HELP!!

By pentos ·
Hi Folks,

I recently installed a RAID mirror array. The system already comprised an IDE C drive containing the OS, and another SATA containing data.

Since the install, the system boots just fine, but on trying to access the SATA (designated E) I get "Drive E is not formatted, would you like to etc"

Ive run a data analysis/recovery tool which pretty much shows that all the files are still there and intact, but hasn't been able to retrieve them all satisfactorily.

My instinct of it is that during the RAID setup the drive assignment has somehow become altered, and if I can just correct it, all my data should be available again. Trouble is, Im not sure how to go about it.

Ive also tried the drive in an external caddy, but with the same problem.

Any help greeted with huge gratitude

Cheers

Jonathan

PS system is as follows:
Asus P4C800 Deluxe MOBO
Pentium 4 3.2ghz
4gb DDRAM
2 WD 500GB HD striped in Mirror RAID array
1 Maxtor 160GB OS drive
1 Maxtor 250gb SATA (Drive E - the problem one)

Win XP Pro SP1

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Check drive assignment first

by bsmith523 In reply to Sata drive inaccessible f ...

It just might be that the new SATA drive is not assigned as E, but something else. Right click on "My Computer" and select manage. Under the "storage" find "disk management". This should show all the drives assigned and some info on each drive. Report back what you find.

Collapse -

Reply (

by pentos In reply to Check drive assignment fi ...

Hi
Ive tried that but with no success. It still shows E but shaded out, and still wants me to format.

I think the issue is one of RAID controller.
I think. i may be able to flash the onboard RAID controller, but not sure if this would free up both pairs of SATA connectors. thoughts?

It may be that the mobo cannot run RAID SATAs and ordinary SATAs at the same time. Anyone?

If I cant get it to play ball by flashing (RAID controller and/or BIOS) it may be that my only choice apart fomr a new mobo is a hardware RAID controller in a PCI slot.

Whaddya think?

cheers

Jonathan

Collapse -

How many SATA controllers are there.

by bsmith523 In reply to Reply (

Typically on a MB with RAID there are 4 SATA controllers. 2 for RAID and 2 for normal. If your solo SATA drive is connected to one of the normal SATA controllers it should be working fine. If you only have 2 or if the drive is connected to one of the RAID controllers then you are out of luck. Each pair of controllers is usually paired so you can't have RAID on 1 and non-RAID on the other. You can always get a SATA to IDE converter and connect to the IDE controller.

Collapse -

how many sata controllers? er...not really sure

by pentos In reply to How many SATA controllers ...

Ive been through the manual, and checked ASUS's site, and even emailed them, but its not really clear.
Ill post s erply if I get one form them, and let you know if I find out any more.

Any other ideas?

cheers

Jonathan

Collapse -

Open the computer and look inside.

by bsmith523 In reply to how many sata controllers ...

You will either see 2 SATA connectors on the MB or 4. If you see 4, they should be color coded in pairs (i.e. 2 will be blue and 2 will be red). If you see 2, you are probably out of luck without adding a PCI SATA controller.

Collapse -

Im missing the boat here

by CG IT In reply to Sata drive inaccessible f ...

let me get your question straight. 1. you use IDE as the boot drive with the O/S on it.

2. you recently created a mirrored SATA RAID array with 2 drives.

3. The O/S can not see the mirrored array you created e.g. says not formatted.


4. Question: Did those SATA drives you used for the mirrored array already contain data?

Collapse -

Array is fine - other SATA not

by pentos In reply to Im missing the boat here

Hiya, and thanks for your reply

Questions 1 & 2 , yup.
Question 3, nope. The OS sees the array just fine. Its the other SATA drive which it tells me isnt formatted, and would I like to format it now.
The RAID SATA's were brand new.
thanks
Jonathan

Collapse -

so is this the setup?

by CG IT In reply to Array is fine - other SAT ...

you've got 1 ATA drive
2 SATA drives in a RAID array mirrored
1 SATA drive not in a RAID array? O/S wants to format it and it's got data on it?

if so, the question is how old a mainboard?

older mainboards [from a couple of years ago] SATA controllers were RAID controllers like SCSI so drives were in a RAID array either striped or mirrored. The newer mainboards SATA controllers see SATA drives either in an array or as individual drives [like ATA].

Collapse -

SATA fact?

by pentos In reply to so is this the setup?

Hiya

Tnx again for your input

The mobo is an Asus p4c800 Deluxe bought, as you rightly say, around Nov '04.
So whats the solution? New mobo? Or can I uprade the controller by flashing its bios? Or indeed, flashing the main bios?

Many thanks

Jonathan

Collapse -

to be honest...don't know

by CG IT In reply to SATA fact?

the SATA controller is an onboard chip. Flashing the BIOS probably isn't going to achieve the results you want.

I would say if the board is older, go get a new mainboard and new dual core processor [with PCIe graphics].

I know the new boards SATA controllers aren't strickly RAID controllers. They function just like the ATA controllers. So you can choose to have just SATA drives similar to ATA controllers AND in addition, create a RAID array of SATA drives.

Back to Hardware Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums