Question

Locked

SBS 2003 with linksys router help

By johnorl ·
We had someone setup our office network and our internet keeps dropping connection. We have the internet connected to the linksys router w/wireless disabled, from the router to a switch to a poweredge 840 server w/one NIC card and the other switch ports to about 12 PCs. The router has been left w/the IP 192.168.1.1, the server is set as 192.168.1.1. The workstations we have set to obtain an IP address automatically and obtain DNS automatically. It works fine, then all of a sudden the internet connections will drop completely. If we reset the router (unplug and plug back in) it comes back up. Does anyone know exactly how we should have the settings on the workstations? Should we manually assign IP addresses or settings? I saw a post regarding setting the default gateways on the workstations but would the gateway be set only and the other fields left blank and the DNS set to automatci or ?? Many thanks

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Problem is not the workstations

by Churdoo In reply to SBS 2003 with linksys rou ...

Did you really mean to say that the router is 192.168.1.1 and the SBS IP is 192.168.1.1? This can certainly explain your problem. Two things on the network should not have the same IP.

You need to run the Change IP wizard on the SBS and change it to something other than .1, say 192.168.1.11 for example. You also need to figure out which device is providing DHCP for your network, the router or the SBS. I recommend the SBS, and if so, go to your router config and make sure that the DHCP server is disabled.

Now on the SBS, DHCP server configuration, the scope options should be set such that the default gateway is the IP of your router (192.168.1.1) and the DNS is the IP of your SBS (192.168.1.11 in my example). Also make sure that the .1 and .11 addresses are not part of the DHCP scope, or are part of the exclusions.

You should not have to do anything to the workstations if they are set for automatically obtain ...

Collapse -

Correction on SBS IP

by johnorl In reply to Problem is not the workst ...

I typed it wrong, the SBS IP is set to 192.168.1.2. The router is now set to provide DHCP. We have the SBS 2003 admin companion book which confirms your recommendation and has the Internet connect to the SBS then to the switch and then PCS. But there is only one NIC card, also on SBS the book says under "Advanced Management, computer mgmnt, services and apps, then DHCP" But there is not a DHCP on the SBS, maybe Dell would not have installed it because there is only one NIC card? or maybe someone removed it?
The one program we use on the workstations uses SQL, the stations drop connections with the program/sql on the server and we have to reconnect. This problem is in addition the internet dropping.
Thank you so much for your patience and help!

Collapse -

Please verify that DHCP is turned off on SBS

by CG IT In reply to Correction on SBS IP

if DHCP is turned off on SBS you will most likely have problems cropping up like the one's you mention.

Workstations get all their information from DHCP unless you use static routing. This includes DHCP options of DNS servers and default gateway. Even if you use static routing on workstations, it's best to leave DHCP running on SBS. If you unauthorize the scope and turn DHCP off on SBS, reauthorizting it will not solve problems. you will at some point have to rerun setup to get it to work. I've had to do restores from backups for clients that had someone who doesn't know SBS turn off DHCP which then causes a lot of problems.

Also, whenever you change SBS, you must, and I can not stress this more heavily, must rerun CIECW and put in the changes.

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums