SBS Connect Computer Wizard problem

By pbrowning ·
I'm in the process of adding a Windows Storage Server 2003 NAS box to an SBS2003 network.

I have set the NAS box to obtain an IP address automatically and set the DNS address to the internal IP of the SBS box. I'm signed in as administrator.

On the SBS box I've run the 'add server computer' wizard and put the name of the NAS box in the appropriate place. The wizard completes OK and I get the mesage to complete the connection from the client. So then on the NAS box I invoke http:\\servername\ConnectComputer and input the appropriate SBS username and password.

Now for the problem:

When the wizard gets to the 'select computer name' section the box is empty - no name to select - zilch, and hence the wizard cannot proceed. There's no error message, just the blank name box and a greyed out 'NEXT' button.

I double checked the computer name on the NAS box, it's OK. On the SBS box I tried running the wizard again and got the error message 'This name already exists in Active Directory'

I'm now stumped. There are no applicable errors in the logs, all the names check out, etc.

Can anyone suggest a way forward? Anything else I can check?

Thanks in advance.


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

open Active Directory users and computers

by CG IT In reply to SBS Connect Computer Wiza ...

find my business OU, expand, find computers OU, expand, find SBS servers OU, expand, your server should be listed.

you can always manually add the server from the server, then move it to the servers OU under My Business/SBS servers OU.

Collapse -

Now the share can't be found!

by pbrowning In reply to open Active Directory use ...

Just been doing that funnily enough.

I added the server manaully and joined it to the domain. I can see the NAS box in the server computers section of SBS but there's still a problem:

If I edit a users home folder path in Profile to a folder on the NAS bax I get an error message that the folder cannot be created because the share or the server cannot be found. The share exists and has the right permissions and I can see the server in AD so what could be the problem?

Collapse -

use folder redirection via group policy

by CG IT In reply to Now the share can't be fo ...

This is a MS KB article on possible causes for an empty folder**1595/en-us

this is an article on how to redirect the my documents folder via group policy and set permissions.

Try these first instead of changing the target folder via user account settings.

Collapse -

Yes, I understand what you're saying but....

by pbrowning In reply to use folder redirection vi ...

... this is not the cause of the problem.

I understand folder redirection via GP and have this set up for the My Docs folder only. The GP redirects each users 'My Docs' to the location of the users home folder and this is set via the user profile. Home folders currently resides on the SBS box and I want to relocate it to the NAS server. To do this I would simply change the path in each user profile.

However, as I said, this is not the problem; here's another stab at explaining it:

The Connect Computer wizard will not complete, it fails at the 'select computer name' entry as the field is blank.

I can add, and have added, the new server to AD manually and it appears in the AD server list. I can browse to it, ping it, connect via TS, etc.

However, I cannot select AD users or groups on the new server, neither can the SBS box create a folder path on the new server, it claims it either cannot find the server or the share does not exist. Obviously the same error is responsible for the connect computer wizard failure.

I can't for the life of me see what is wrong. Any further ideas?

Collapse -

fuzzy on the select AD users or groups on the new server

by CG IT In reply to Yes, I understand what yo ...

if as the domain administrator, you can not create a new shared folder on the new server [NAS box] that's a problem and indicates that the server really isn't a member of the domain.

The connecto computer wizard sometimes works, sometimes doesn't work. If the select computer name field is blank, all that indicates is that the computer isn't in the right Active Directory users and computers My Business/SBS OUs. This happens when you manually add the computer to the network however it doesn't mean the wizard failed. It means the wizard, when it looks in the OU, can not find a computer account that matches the computer your trying to add which circles back to using the add computer wizard instead of manually adding the computer. The wizard places the computer account in the correct OU where manually adding a computer does not.

Note: after changing the computer [or servers] workgroup or domain designation you have to reboot for the changes to take effect. If you do not reboot, then the default workgroup designation applies. The default workgroup acts as a security boundary which would deny the SBS box from mapping to a shared folder on the NAS box.

The shared folders available to the domain are listed in My Network Places. If you use the shared folder wizard, these shared folders are browsable via Active Directory.

Related Discussions

Related Forums