Question

Locked

SCHTASKS ERROR

By jimmy-jam ·
I am trying to use schtaks to schedule a task on a remote server on our network. The server is on a child domain with it's own GCS so my credentials I am logged into my PC with will not work. I have credentials on the remote machine and can run the schtasks command supplying these crentials in the command line. The task scehdules and shows up in the scheduled tasks of the remote machine but it will not run. It displays could not start. If I go into the properties of the task before it is supposed to run and supply the password the task will run. When I run the schtasks command the output tells me that the task was created but then gives me a warning which states "WARNING: The scheduled task has been created, but may not run because the account information has not been set." So apparently the password info is not being passed. See below for the syntax I am using. What am I doing wrong?

c:>schtasks /create /s \\server /u domain\user /p password /ru domain\user /rp password /sc once /tr c:\task.vbs /st hh:mm:ss /tn taskname

Thanks
Jim

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

bump

by jimmy-jam In reply to SCHTASKS ERROR

Sorry for the bump but I dropped off the list. Can any one help????

Collapse -

Try "System" user?

by Bizzo In reply to SCHTASKS ERROR

You could try running the task as the "System" user.

Use the /ru "System" switch, /rp is not required.

More info:
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/schtasks.mspx?mfr=true

Collapse -

tried that

by jimmy-jam In reply to Try "System" user?

I did try that but the command prompts me for a password which I didn't think was supposed to happen. Any other suggestions?

Collapse -

Admin Rights?

by Bizzo In reply to tried that

The username and password you're supplying, does it have admin rights for that machine? Or the correct rights to create scheduled tasks? try logging into the server with that user and see if you can create the task manually.

Collapse -

Yep

by jimmy-jam In reply to Admin Rights?

I can (and have) create tasks manually. Also if I run the schtasks command with the credentials I have it puts the job in the scheduler. If I then go into the schedluer and manually set the password the task will run. Kind of defeats the purpose. It just seems like my password isn't going across when I run the command.

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums