General discussion

Locked

Screen flicker

By Ian Boothby ·
Asus A7N8X-X mobo. 512mb Twinmos DDR. AMD2500. This PC is bugging us - its had 2 AGP graphics cards in (Radeon 9600 Pro & Geforce 5600 both 128mbDDR) and with each it flickers when you try to play a GAME(tried Black Hawk Down/Mother Truckers/Gun Metal etc). Windows/DVD movies/WMP graphics all perfect.

Have updated mobo bios and videocard bios but still flickering. Have turned all game settings to min AND tried 16 and 32 bit with and without anti-aliasing on. Have tried with different monitors-still same. Both cards run OK in other PCs.

Where to go from here please!?????

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by parvus1202 In reply to Screen flicker

change display to 85-120 mgz

Collapse -

by Ian Boothby In reply to

nothing above 85mhz available

Collapse -

by TheChas In reply to Screen flicker

Start by checking your AGP aperture size in BIOS settings.

It needs to be at LEAST as large as the video RAM.
Preferably twice video RAM.

Next, which version of Windows are you running?

Windows 95, 98 and Me all have a bug that can be triggered with more than 511MB of system RAM.

If you are running Windows 9X, try reducing RAM to 384MB and see if that corrects the problem.

Another 9X issue could be remnants from each video card driver impacting the other.

Also, some Windows 9X components create problems with CPUs faster than 2.1 GHz.

Which version of DirectX is installed?
And, which version do the games require?

From the run box, run dxdiag to check DirectX functionality.
The tests may point to the cause of the problem.

What about the drivers for the motherboard?
Do you have the latest drivers for the chip-set installed?

Chas

Collapse -

by Ian Boothby In reply to

Thanks for your input!

Aperture is 512 so should be ok.

Running Win XP Home with SP1 + ALL updates.

DX9b - all tests passed OK (as do the games on the installation test - they all allow the top settings!)

Mobo only 3 months old - orig driver disk caused flicker, but so do latest updates from Asus/nVidia.

I have tried slowing down acceleration and turned off other options in video settings troubleshooting too.

Any other suggestions please?

Collapse -

by TheChas In reply to Screen flicker

Reduce size of AGP aperture.

Your AGP aperture is too large.
You should not "normally" set the aperture larger than 1/2 system RAM.

With the aperture set to the same size as system RAM, the game and the video card can attempt to use the same RAM space.

Either increase system RAM to 1GB, or reduce the aperture to 256MB.

Have you checked with the game manufactures for XP updates?

Chas

Collapse -

by Ian Boothby In reply to

Originally ran with 128mb aperture & tried 512 & 256 - all do not reduce flicker/sharding.

Have downloaded & installed all updates from game manufacturers. weird thing is that 2 of the games came with the video card as freebies to show the power of DX9!

Gotta go to bed now (midnight in UK) but please add anything else you can think of & I'll look in the morning.

Have a good one friend!

Collapse -

by Ian Boothby In reply to Screen flicker

This question was closed by the author

Back to Desktop Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums