Seagate FreeAgent Go 320 GB is not detected on my machine

By oarjun ·
Hey there!

I Purchased a 320GB Seagate FreeAgent Go USB Hard Drive few months ago.

My System Configuration is...

AMD Athlon XP 1800+ processor...
ASUS mother board
recently i purchased USB 2.0 version slot with 4 ports...

Initially(when i purchased the new USB drive) I am able to use it with my system(which i mentioned above). After few days system not able to detected the drive. If I plug it to system only power light is working. System is not detecting the drive.

I tried to make it in different ways, but not worked...

Could you any one please give me the suggestion.


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Here you need to look in the Drive Management

by OH Smeg Moderator In reply to Seagate FreeAgent Go 320 ...

And see if the drive is actually being seen by the system or not. Just because it doesn't show in My Computer or Windows Explorer doesn't mean that the system is not seeing the drive.

If the drive is showing in Drive Management as RAW the Partition Tables have been corrupted by not using the Safely Remove Option on the Windows Task Bar.

If you are using this through a PCI USB Card you may not have enough power available from the Computer to work the drive properly.

In that case you'll need to use either a Y Cable with 2 USB Plugs that plug into the Computers or a External Power Supply for the Drive Enclosure. USB Ports are supposed to have 500 Milli Amps per socket but quite often with PCI Cards this amount of power is not available so you need to supplement the necessary power.


Related Discussions

Related Forums