Question

Locked

Seagate FreeAgent Go external drive won't work

By Trish44 ·
We just bought new Seagate FreeAgent Go external drives for my computer & my husband's. I can hook them both up to my computer & they run fine. My computer found new hardware & I can now look at the files on the drives. When I hook them up to my husband's computer they just blink & nothing happens. There is no new hardware found & I can't access the drives. I tried installing an extra USB hub on the front of his computer that is hooked to a PCI card on his motherboard, but this made no difference. He still has the same issue. I know that these drives need plenty of power. His motherboard is an ASUS A8N-SLI & he has an Antec case with an Antec Truepower 550W power supply. We're both running Windows XP. We can hook up other USB powered peripherals such as a mouse & flash drive & they work. The USB 2.0 is enabled in the bios for the motherboard. Does anybody have any ideas why this drive won't work on this computer?

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Are you using the USB splitter cable that came with the drive?

by robo_dev In reply to Seagate FreeAgent Go exte ...

On some laptops with wimpy usb ports, I've had to plug the power half of USB splitter cables into separate USB power supply or powered USB hub to get enough power.

It wont hurt anything to plug the power-side of the USB splitter into your machine, and plug the data side into your husbands machine...this could verify that it's a power problem.

Collapse -

Another thing to look at

by OH Smeg In reply to Are you using the USB spl ...

With the USB Y Cable that was supplied with this device the One closest to the HDD is a Power & Data Plug while other the USB Plug is a Power Plug Only.

If you are not plugging in the Power & Data Cable Windows will not see any new device as there is none there. There is only the HDD consuming Power but as there is no Data Connection to the HDD it can not be identified or seen. You need to correctly connect to the Desktop computer.

Though with this type of M'Board I would suggest using a Powered USB Hub as apposed to installing a USB Card. You can add up to 128 USB Devices to any one USB Port with the use of Powered USB Hubs. So unless you need the extra USB Ports for the USB Devices that you have it is better to get the power for them from outside the computer instead of attempting to draw it through the M'Board.

Col

Col

Collapse -

OK, thanks

by Trish44 In reply to Another thing to look at

Yes, we were plugging in both sides of the Y-Cable & it still wouldn't work. If I understand you correctly you're saying that we should use an external USB hub that plugs into the computer rather than one like I have used plugged into the PCI slot on the motherboard. Is that right? We'll have to get one & try that next. Thanks for your suggestion.

Collapse -

You need to use a POwered USB Hub

by OH Smeg In reply to OK, thanks

As apposed to just a USB Hub. the type you need has it's own Plug Pack and supplies 550 Milliamps to each USB Port.

If you use a unpowered USB Hub it will still be drawing all the power throught 1 USB port on the Plug In Card and through the computer so you would be no better off.

Col

Collapse -

Just out of curiosity

by OH Smeg In reply to OK, thanks

Are both OS's the same on the different computers.

It is just possible that a HDD formatted on XP may not be seen under Vista. If that is the case here you will need to format the HDD on the Vista Computer and then copy the stuff to it from the XP Computer.

If you need to format the HDD under Vista Open the Drive Management Window and right click on the USB Drive there and select the Format Option.

Col

Collapse -

Running same

by Trish44 In reply to Just out of curiosity

Both computers are running XP. I got a powered hub & will be trying that today. I'll let you know how it goes. Thanks!

Collapse -

It works!

by Trish44 In reply to Running same

Thanks to everybody who replied for your help! I hooked up the powered hub today & voila it worked. I still don't understand why it worked on my computer & not on my husband's, but maybe it's just a difference in motherboards. We do have different motherboards at this point. Mine works fine with a non-powered USB hub hooked to my motherboard. However, my motherboard is a couple of years newer than my husband's. Oh well, who cares why as long as it's working now. Thanks again!

Collapse -

external drives, Free Agent probs

by Dr Dij In reply to It works!

On any USB HD drive, if you power off the drive without doing the shutdown of the drive or your PC, or if the drive loses power during power fluctuation or outage, it will corrupt the drive and/or free space table.

If this happens, copy stuff off it if you need to and can, reformat it and put it back on, and get a mini-ups for your computer and the drive.

I have two older silver seagate usb drives, 300 gigs each and love them. They are rock solid and I backup critical directories to this and store them off site.

But I bought a 750g freeagent drive but had to return it for the following reasons:
it got very hot on the bottom. I was getting worried about the wood shelf I had it on.
The touch capacitance button turned it ON ok but no matter how long I held it would not go off. (even with computer shut down before this)
If I left it connected during boot on my w2k system would freeze the whole computer BEFORE IT BOOTED.

I have a bios password AND I have the computer set to boot off ONLY HD and it would not even get to this! Very bizarre! Yet if I waited till booted, then plugged it in, I could see my files I had copied over there.

Seagate tech just blew off my request to figure out these problems so back it went to Fry's.

It has some kind of system software on it which must be causing these problems. Other hard disks don't have mystery software on them.

Collapse -

Your Welcome <NT>

by OH Smeg In reply to It works!
Back to Hardware Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums