General discussion

Locked

Security Tab Missing on Win2K folder

By forbesn ·
I have a Win2K server running IIS 5 as our web server. Yesterday afternoon one of my subwebs stopped working (Access denied). There is no security tab (or Web sharing tab either) on that folder. All other folders appear to be fine.

I've tried logging in as the Domain Administrator and with a local Administrator account to no avail. I've tried resetting ownership from the parent folder and received "Access Denied" errors. I've tried resetting permissions using XCACLS/CACLS and received the error "No mapping between account names and security IDs was done"

I'm stumped. I'd gladly delete the folder and republish from my staging site if I could get rid of it but I can't open it, delete it, rename it, etc.

I haven't tried restoring it from a backup but I'm pretty sure I'd get an access denied error as well since the directory permissions are corrupt.

How do I repair them?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Joseph Moore In reply to Security Tab Missing on W ...

Did you try to Take Ownership of the root folder for the subweb? Even when the Administrator account is Denied permissions, Taking Ownership will over-write any permissions removal.
But, if the Security tab is missing on the root subweb, then this is harder.
So, go to the folder above the subweb folder and try to take ownership, and I think that will pass through to the folders with your subweb.
So, go to the folder, right-click -> Properties -> Security tab -> Advanced button -> Owner tab.
In the Change Owner To box, select your Administrator account and start click OK.

IF the ownership setting trickles down to the subweb folders (I think it will, but I am not totally sure right now), then you should then have FC rights to the subweb folders/files.

hope this helps

Collapse -

by forbesn In reply to

I had already tried that. The parent folder mentioned above was the root folder for the web.

We scheduled a Check Disk to start in DOS mode on our next reboot and then rebooted the web server. When we did that, it ended up completely deleting the problem folder. Obviously something was corrupt. I then was able to recreate the subweb and get it back up.

From my logs, I've been able to approximate when the corruption occured. I still don't know why. We loaded Service Pack 4 on Friday along with KB828749 but we weren't doing any publishing or other administrative tasks on the server on Monday.

Collapse -

by forbesn In reply to Security Tab Missing on W ...

This question was closed by the author

Back to Windows Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums