General discussion

Locked

Server 2000/XP clients, logon issue

By patriccio ·
Hello. A network engineer and I run a small network for a non-profit. I get paid a little, he doesn't; for a while now, we've had ongoing issues with a particular program, Logos Church Management. The accounting program is fine (it's single-user), but the church management program, a multi-user setup, has seemingly mysterious problems with client logins. It worked fine for three days straight recently, then one day, it suddenly disallowed any client logins. Over time this has been a pattern. It works fine for a while, then wa-la, with no warning, it disallows client logins.

The server, which houses the actual data, is fine; one can login to the program there and do input, no problem.

We're running Win 2k Server, with mostly XP Pro clients. It's a single domain with only 8 or 9 clients. The program is loaded on the server as a network server, and each client is loaded with the client version of the same.

After lots of calls into tech support for Logos, they and I are convinced the problem isn't the software; it seems to be our domain configuration, or our lack of configuration. It may be permissions, it may be we haven't connected things right, or something else.

I hope I've given enough info to give you some helpful ideas. If further info is needed, I'll post it ASAP.

Thanks.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by patriccio In reply to Server 2000/XP clients, l ...

Point value changed by question poster.

Collapse -

by sgt_shultz In reply to Server 2000/XP clients, l ...

1) do you have domain or workgroup?
2)when this happens, can any computers get in?
3)is everybody using same windows username and password?
4)when this happens, can you browse to church program folder on server, enter and view contents off all folders? if no, logon as administrator, repeat test...
when you told logos you are running single user package in multi-user environment, they said that was known to be done ok?

Collapse -

by patriccio In reply to

Poster rated this answer.
1) We use a domain. "cbsr.org" is the domain name as listed on the server; on the clients it's listed as "cbsr". Clients have the option of logging into their computer (computername) or to the cbsr domain.
2) When this happens, no one can get in to the program, not even administrators, except on the server itself. These are the error messages received when the client is trying to log in:
[each error message has the option of 'Cancel', Ignore' or 'Help'] "Error reading file" [press ignore between each message...], "Invalid seek offset", "Invalid seek offset",
"Alias 'APPINCL' not found", "Variable 'string' is not found", "Alias 'APPINCL' not found", "Function argument value, type, or count is invalid", "File is in use","Alias 'APPINCL' not found","Alias 'APPINCL' not found","Function argument value, type, or count is invalid","Alias 'APPINCL' not found", and finally "Function argument value, type, or count is invalid". These error message sound like attempted initialization scripts that aren't connecting due to being 'kicked off' the network somehow.
3) On the domain, each user has a separate username and password. The software is the same - there are different usernames allowed to login to the program, each with a different password.
4) When this happens, as administrator I can access/view the folders on the server and see what's there. Before this issue came up, we had problems on the server, and their support people had me reload the whole program and restore the data; that worked fine until the single-user error came up (we pay for a multi-user license). Their explanation was that the single file that held that information got corrupted on the load, so he had me reload the whole thing again, and that's when everything worked smoothly for three days.

After that, when I called their support people, they and I concluded it was a network issue - they've never seen this before, and I have a sneaking feeling we're overlooking something basic and simple here in our domain setup. It could be the software though...

Hope this gives you something to go on.

Collapse -

by Duster52 In reply to Server 2000/XP clients, l ...

It could be a user-induced error. It sounds like a file(s) is getting locked and the application is not releasing it for anyone else.

Are all of the users exiting the application correctly? Not just clicking on the 'X' in the upper right corner, or just turning off their computer?

See if you can make it lock up by doing improperly exiting the app...If you can, then it becomes a training issue.

Collapse -

by patriccio In reply to

Whoa! Figured it out, and I'm amazed we didn't see it sooner - it wasn't the software/network settings at all. HARDWARE - a switch port handling the traffic was configured to go on and off at different times. So the explanation of why it would work, then all of a sudden not work finally made sense. Thanks for your input! Next time I'll not assume it's software-related; what do they say about the physical layer, 90% of the problems are found there? (In this case, I guess the data link layer).

Question closed.

Collapse -

by patriccio In reply to Server 2000/XP clients, l ...

This question was closed by the author

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums