Question

Locked

Server 2003 R2 SP2 - Network shares to remote building disconnect.

By epfaffinger ·
First post....

Brief description:

We have two buildings connected via two devices owned by our isp. It's not a vpn, the device basically just forwards all traffic from one building to another. Both buildings are on different subnets and our firewall/vpn device at our main building routes traffic. No changes have been made to the firewall/vpn device.
I have recently implemented a new AD domain using a new 2003 R2 SP2 server. along with both 2003 and 2000 member servers. I also implemented a new Exchange 2007 server on Windows Server 2003R2x64. All clients run 2000 Pro SP4 or XP Pro SP2.

Problem Description:

Almost two weeks after implementation users in the remote site could no longer access data on the primary domain controller. to my knowledge no changes were made to any security/network/file share settings.

I can ping the pdc from the remote subnet using either it's name or ip address, nslookup does not pinpoint any dns issues. I can see the shares using \\servername and I can map drives no problem. Logion scripts run without error as well.

however, if I try to copy a file from the pdc to the workstation it starts and then almost immediately fails with the error:"The specified network name is no longer available".

If I try to open a file (spreadsheet, pdf, word doc, etc.) I get the following error: "file cannot be access. The file may be read-only, you may be accessing a read-only location, or the server the file is on may not be responding".

Also, on the win 2000 clients the mapped drives show up as disconnect and if you leave windows explorer open they sometimes change the name from the format folder name on server (shared on pdc (S:)) to just "Network folder' (Network Folder (S:)) and when clicked respond with the message: "The local device name is already in use, the connection has not been restored". Clicking 'ok' and trying again will usually result in the shared data being displayed but nobody can access it, read from, copy from, or save to the shared drives.
This problem is only with our Domain Controller. If I setup test shares on other member servers, even 2003 R2 member servers they can be mapped, read, copied from, saved to, and files can be opened.

I must admit I am baffled. I have checked security on the shared folders and I have full access. The firewall service on the DC is turned off.

Does anyone have any idea what could cause such a problem. The local subnet in the building where the server is located does not have any issues.

At first I thought it might be an issue with the device the allows the data to go from one building to the other but after further testing and seeing the symptoms I have posted here I'm not so sure. It points to an issue with only the PDC and only from traffic coming from the remote subnet but I don't know where else to turn now.

I do not have a backup domain controller at the remote site...do you think this would help?

One more piece of info I gathered in my testing. If I create a vpn in windows networking on the client and connect to our server using this vpn client they can then access the shares and data ok, disconnect the vpn and the problem comes back. I don't really want to buy hardware devices to create a vpn tunnel between buildings as the configuration did work up until last week?

Any insight would be much appreciated.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

This community blows

by epfaffinger In reply to Server 2003 R2 SP2 - Netw ...

Zero replies, thanks for nothing. Techrepublic blows, just another spam mail generator, what a waste of time.

Collapse -

Are you quite finished?

by IC-IT In reply to This community blows

Calm Down. Perhaps when you posted a bunch of us were busy or a lot of posts were made or a lot of folks had gone for the day and your post scrolled out of range before anyone with the skills to help you noticed it.

A simple bump or edit would have brought it back on radar.

Collapse -

"Feature" in Windows Server 2003 SP2 can cause intermittent file browsing f

by jeffkientzler In reply to Server 2003 R2 SP2 - Netw ...

There is a feature called ?TCP Chimney? that gets turned on by default in Service Pack 2 for the following products; this feature has been reported to cause intermittent failure in accessing file shares:

? Windows Server 2003 (Standard and Enterprise)
? Windows Server 2003 R2 (Standard and Enterprise)

Symptom:

You are able to ping <servername> successfully, but you are unable to browse to a \\<servername>\<sharename> share that is hosted on the server. This inability to browse file shares is intermittent, meaning that it may come and go throughout the day or that it may manifest itself when accessing the server from one location but not another.

Confirmation:

To confirm that TCP Chimney is the cause of the issue, open the Registry Editor and browse to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

If the key EnableTCPChimney is present and has a value of ?1?, then the TCP Chimney feature is installed and enabled on this server.

Resolution:

From the command prompt on the server, issue the following command (case-sensitive). No reboot of the server is necessary, and network connectivity and other network services will not be interrupted:

netsh int ip set chimney DISABLED

Once TCP Chimney is disabled, file share access should be restored almost immediately.

Collapse -

Thank you!!

by chris.a.libby In reply to "Feature" in Windows Serv ...

After MONTHS of aggrivation and annoyance caused by this very problem, I've finally found this post! Looks like it solved my problems!

Collapse -

Unfortunately this did not help

by it In reply to "Feature" in Windows Serv ...

Jeff,

Thank you so much for replying, I admit I was frustrated at the lack of response and really had my hopes up that this would fix my issue. However it did not. Indeed TCP Chimney was enabled on the server but disabling it did not help (incidentally could you not also just change the reg value from 1 to 0?) I followed you instruction and the problem remains.

Also shared printers fluctuate from a status of 'ready' to 'opening' to 'unable to connect' and back again in front of my eyes?

I have 12 servers with 11 of them being in my main office and 1 in my remote site (setup in AD sites and services). I have noticed that the network share/file copy/printer issues only happens when the remote site tries to talk with the Primary Domain Controller. It does not happen with any other server but I did notice that TCP Chimney was enabled on all servers running Server 2003 SP2?

Any other ideas, I have searched in vain for months and this is creating huge problems as the PDC is also my main file server so users are experiencing many problems trying to view data?

Collapse -

Solution?

by siljehb In reply to Server 2003 R2 SP2 - Netw ...

Did you ever resolve this?
I got the exact same problem, and I have tried everything i can think of. Very frustrating.

Would be greatly appreciated!

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums