General discussion

Locked

Server running out of Inodes

By steven_bellamy ·
Hello,

I have a RedHat 7.3 server running squid proxy server.

Every few months my proxy server keeps running out of Indoes as the cache grows.
When I do a df -i, the IFree field is 0.

How do I permanently increase the number of Inodes on the server?

Thanks

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Server running out of Inodes

by Cactus Pete In reply to Server running out of Ino ...

You need to increase the size of the partition, or add a disk...

Collapse -

Server running out of Inodes

by steven_bellamy In reply to Server running out of Ino ...

The question was auto-closed by TechRepublic

Collapse -

Server running out of Inodes

by bcbvale In reply to Server running out of Ino ...

I'm not sure about linux but in solaris you can specify the number of inodes using the -i option with the newfs command. Of course this means that you have to do this when creating the file system and cannot change it without destroying your data.

Collapse -

Server running out of Inodes

by steven_bellamy In reply to Server running out of Ino ...

The question was auto-closed by TechRepublic

Collapse -

Server running out of Inodes

by gigsvoo In reply to Server running out of Ino ...

Here is another alternative that might solve your problem (actually squid has this problem)... use OOP proxy server. http://www-105.ibm.com/developerworks/education.nsf/linux-onlinecourse-bytitle/BA954CF013E79EA886256A70005C5914?OpenDocument

Collapse -

Server running out of Inodes

by steven_bellamy In reply to Server running out of Ino ...

The question was auto-closed by TechRepublic

Collapse -

Server running out of Inodes

by paulo.sedrez In reply to Server running out of Ino ...

The number of inodes are stablished by filesystem when it is created. You must recreate the filesystem to change the number of inodes. Use '-i 1024' (1k per inode) to create a filesystem with enough inodes.

Of course, I am assuming you create a partition dedicated to squid cache. If you did not, I sugest you do, and mount it with 'noatime' option - this will speed up things.

If you have little space to create a new partition for squid cache, use parted to resize some of your partitions and make room for a new one.

--Sedrez

Collapse -

Server running out of Inodes

by steven_bellamy In reply to Server running out of Ino ...

The question was auto-closed by TechRepublic

Collapse -

Server running out of Inodes

by steven_bellamy In reply to Server running out of Ino ...

This question was auto closed due to inactivity

Back to Linux Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums