General discussion

Locked

Setting a default text editor i

By janeDL ·
I know I saw an article on how to set a default text editor for Windows NT4, but I can't find it. I want to set Notepad as my default. How do I do that and/or how do I find the original article?

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Setting a default text editor i

by Haissam In reply to Setting a default text ed ...

Jane,

1. Go to the key "HKEY_CLASSES_ROOT"
2. create the subkeys \*\shell un HKCR
2. Under shell create a new key called open, and edit the string "(Default)" to read "Edit With Notepad".
3. Under open create a new key called command, and editthe string "(Default)" to read "notepad.exe %1".

This will set Notpad to be your default browser.

Regards,

Haissam

Collapse -

Setting a default text editor i

by janeDL In reply to Setting a default text ed ...

I tried it on a workstation running Windows98 and it didn't work. Is this for NT only?

Collapse -

Setting a default text editor i

by dapowers In reply to Setting a default text ed ...

Go into Windows Explorer and change the file associations for the .txt extension to notepad.exe. Should be under the tools-> options submenu.

Collapse -

Setting a default text editor i

by janeDL In reply to Setting a default text ed ...

The question was auto-closed by TechRepublic

Collapse -

Setting a default text editor i

by dlw6 In reply to Setting a default text ed ...

The other answers are technically correct, but I thought you might want this with more detail.

1. On your desktop, click Start..Programs..Windows NT Explorer. This opens NT Explorer.

2. On the menu, click File..Options. This opens the Explorer Options dialog.

3. Click the File Types tab. In the Registered File Types Window, scroll down until you see Text Document and click to highlight it. If you do not see Text Document, skip to #5 below.

4. With Text Document highlighted, click the Edit button. This opens the Edit File Type dialog. Halfway down is the Actions box. Click OPEN to select it, and click the Edit button. Paste the following into the box titled Application Used To Perform Action:

%SystemRoot%\system32\NOTEPAD.EXE

Skip to step 7.

5. If the Registered File Types window did not include the Text Document, you will have to add it. Click New Type to open the New File Type dialog.

6. There you can add a Description ("Text Document"), Extension ("TXT"), and Content Type (leave it blank). Then, click the New button. Here you specify the Action ("open") and the application name ("NOTEPAD.EXE").

7. Click OK to get out of all the dialogs you opened until you are back in NT Explorer. Find a text file and double-click it to test the changes you made.

Enjoy!

Collapse -

Setting a default text editor i

by janeDL In reply to Setting a default text ed ...

I'm now using a workstation running Windows98 and don't see option under tools. How do I do this in Windows98?

Collapse -

Setting a default text editor i

by dlw6 In reply to Setting a default text ed ...

How embarrassing! I made an error in typing my answer.

Step 2 should read, "Click the menu View..Options."

The rest of my answer about changing the File Types should work after that. Sorry about that.

Don

Collapse -

Setting a default text editor i

by janeDL In reply to Setting a default text ed ...

Well, we are getting close, but still not what I need. What I'm looking for is a default when I am editing a file that has NO extension, such as the Hosts file. Any ideas here?

Collapse -

Setting a default text editor i

by dlw6 In reply to Setting a default text ed ...

Stay on target...almost there...

Let me try this again, now that we've narrowed the problem down. I just tested this with Win95 and NT, so it should work with Win98.

1. In Windows Explorer, right-click on the Hosts file.

2. IF there is no file association for blank extensions, which is most likely, one of the options will be "Open With..." Select that and you should get a "Click the program you want to use to open file 'Hosts'."

3. Select the NOTEPAD entry. You can also check the "Always use this program to open this type of file" box if you want. Click OK.

Note: On my current NT system, the "always use this program" option doesn't work on blank file extensions, requiring me to specify Notepad each time. But it works on a different NT system with the same service pack. I don't know why. If it doesn't work on yours, I'm out of ideas for solving your original problem of making it the default.

Good fortune,
Don

Collapse -

Setting a default text editor i

by janeDL In reply to Setting a default text ed ...

The question was auto-closed by TechRepublic

Back to Windows Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums