General discussion

Locked

Setting up a Belkin USB wireless adapter

By Senor Jefe ·
I've just installed Fedora Core 4 on my computer and would like to set up my Belkin F5D7050 USB wireless adapter. I know that there are several ways of doing this and I have tried two and haven't had success. How do I set it up? I've used ndiswrapper, lastest version, and the RT2x00 SourceForge Project. ndiswrapper seems to be the easiest, but still no cigar. I'm very new to linux so you'll have to use very simple terms and steps. I would appreciate any help.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by sarahmeggs In reply to Setting up a Belkin USB w ...

Hi,

would be good to know what you mean by "not working". How far does it get, what symptoms are you seeing, have you checked the log files (/var/log/messages for example) for clues. Do you know if your system is recognising your card? To check, you could run dmesg or have a look in the /etc/sysconfig/hwconf file to see if it is listed.

Check this site, if you haven't already done so
http://www.tldp.org/HOWTO/Wireless-HOWTO.html

Unfortunately sometimes there isn't a simple "this is how you do it", sometimes you have to have a little poke and play. Best way to learn (sorry to be cliched).

ta, sm

Collapse -

by Senor Jefe In reply to Setting up a Belkin USB w ...

Yeah, I understand that there isn't any exact "how to do" help files, but I do understand that there are people out there that have gone through the same experiences as I'm going through, but with that onto the problem. I get to where ndiswrapper accepts my .inf file and recognizes it, but it doesn't say that my hardware is there. I use dmesg though and it says that a USB device has connected when I plug it in. After I do "modprobe ndiswrapper" I check the dmesg and this is what I get
"
ndiswrapper version 1.2 loaded (preempt=no,smp=yes)
ndiswrapper: driver bknusb (BELKIN,11/11/2003, 1.00.5.0) loaded
ndiswrapper (NdisWriteErrorLogEntry:314): log: C000138A, count: 3 (c0000001), return address: f8d66c73
ndiswrapper (ndiswrapper_add_usb_device:363): Windows driver couldn't initialize the device (C0010006)
ndiswrapper: probe of 1-6:1.0 failed with error -22
usbcore: registered new driver ndiswrapper

"
Any ideas? Thanks for the help

Collapse -

by jmgarvin In reply to Setting up a Belkin USB w ...

Are you sure you have the Fedora wireless tools installed? What happends when you type the command modprobe ndiswrapper?

Did you follow these steps?
1) cd ndiswrapper-1.2
2) make distclean && make && make install
3) ndiswrapper -i <filename.inf>
4) ndiswrapper -l
5) modprobe ndiswrapper
6) dmesg
7) ndiswrapper -m

Now, if you have wireless tools installed, you should be able to click Applications -> System Settings -> Network. Then click New -> Wireless Connection -> ndiswrapper

You should be all set.

Collapse -

by jmgarvin In reply to

Oh, are you sure your USB ports are working properly?

Collapse -

by jmgarvin In reply to

What .inf file are you using and what is the exact nomenclature of your Belkin USB wifi adapter?

Back to Linux Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums