General discussion

Locked

shared printer permissions

By Blackcurrant ·
Hi

I am still having problems with permissions on my domain... I have a printer shared on an XP Pro machine. When I try to connect to this printer from a Win98 SE machine (also on the domain), I get a dialog box asking for a password. What password???

The domain users are listed in Control Panel/accounts on the XP machine, and I have set up the same users as local users: domain\user and local machine\user are all listed. The users have exactly the same username and password for the local account as they have for the domain account.

When I access the printer properties on the XP machine and select the security tab, all the local users are listed but not the domain users, I have however made both domain and local users members of the local machine\power users group. The power users group is listed with full printing permissions. I cannot add domain users because the only location I can add users/groups from is the local machine, and the domain is not listed when I click the 'Locations' button.

When I log on to one of the Win98 machines with my own administrative domain account, I can print without being prompted for a password. As I said, the same (low) level of security is assigned to all users and groups in the printer properties security page.

Do I need to change the account details on the domain controller?

Please can someone help me reduce my stress levels...

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by ctmoore1998 In reply to shared printer permission ...

If the XP Pro is a member of the domain, then you should need to create any users on it to access the printer. You should be able to add the domain users that already exist on PDC. You should be logged onto the XP pro as a domain administrator and the DA acct should be added as a local administrator acct, then you should be able to see the domain users in the security tab by clicking on the advanced then find now in the security property windows. As another note I never run the sharing wizards of XP I always opt to just share the resource lot less run around that way.

Collapse -

by Blackcurrant In reply to

Hi CTmoore, thanks for answering. OK here's the situation: I log on to the XP machine as a domain administrator. I then access user accounts from control panel, and see my domain admin account listed as an administrator for the local machine. I click the next tab, select the Advanced button for users and groups, which brings up the users and groups folders. I click the groups, right-click Power Users, select Properties and see unknown accounts - an icon with a head and question mark followed by a string of numbers. Is the XP machine communicating properly with the domain controller?

Also, I have tried uninstalling and reinstalling the printer and setting the permissions again - I have added the power users group with full permission to Print, manage printers and manage documents. When a user logs on to the Win98 machine, the password prompt appears.

Also, even though I am logged on as a domain admin, when I set the printer permissions, I can only see local users and groups, the locations button only displays the local machine.

Collapse -

by Curacao_Dejavu In reply to shared printer permission ...

On the win98 box go to the dos prompt, in the c:\windows folder and delete all *.pwl files.

then make sure the primary login is client for ms windows.

And make sure the accounts that you are using are !exactly the same ! on the win98 and the xpmachine

You are receiving the prompt because there is a mismatch somewhere

Leopold

Collapse -

by Blackcurrant In reply to

Hi Leopold, thanks for answering. A password had not been set for the printer. The only *.pwl files were username.pwl and deleting these simply caused the system to ask for confirmation of the username password after Windows 98 had loaded.

Collapse -

by Tictag In reply to shared printer permission ...

Just further on from Curacao, also check any mapped drives you have with specific logon credentials. If Win9x connects to a machines mapped drive, it uses these credentials on all other connections. This can cause problems if the specific credentials do not have permissions to access other resources.

Not an answer as such, but something to check.

Regards,
Tictag.

Collapse -

by Blackcurrant In reply to

Hi Tictag, thanks for answering. No specific credentials are used to log onto mapped drives.

Collapse -

by Blackcurrant In reply to shared printer permission ...

Thanks to everyone who contributed to this. I have now solved the problem. I logged on with my domain admin account and uninstalled, then reinstalled the printer. Next I added the printer on the Win98 systems and got the password prompt. Today, I removed the printers and checked the network settings on the XP machine. I had previously installed an internet sharing program before joining the machine to the AD domain. This had set the DNS to point to the machine (not yet on the domain) that holds the modem. After joining the domain, the Small Busisness Server network client setup program had not changed the DNS so that it pointed at the DC. Changing this made the XP machine respond much faster during logon - suprise suprise!!

Next I discovered that the reason that the printer could not be added was because the XP machine had been displaying the wrong sharename. After typing the correct \\printserver\sharename it went like a dream. I do not know why the printer sharename on the XP machine had not been updated.

Collapse -

by Blackcurrant In reply to shared printer permission ...

This question was closed by the author

Back to Windows Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums