Shared Printer Spooler Locks up

By andres28 ·
I am having a problem printing to a shared printer. The printer is an HP LaserJet 1018. The printer works fine locally but when certain users try to print from their workstations over the network the print spooler locks up and has to be reset. Once the spooler is restarted all the print jobs come through just fine. But once someone tries to print over the network the job just sits there in the queue and backs up any other jobs that get sent to it. Does anyone have any ideas?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Driver issue

by bart777 In reply to Shared Printer Spooler Lo ...

Have those network users remove the printer and the driver for that printer.

Then reattach the printer on those network machines. You should be fine after that.

Collapse -

Drivers reapplied

by andres28 In reply to Driver issue

Already tried that. No help. Removed drivers from workstation and downloaded new ones from the website. Still no help. This problem happened before for one of the users. I deleted her profile and recreated it and it worked fine. But now its happening again and its affecting more people. Please help.

Collapse -

Ok, try a generic driver

by bart777 In reply to Drivers reapplied

Either try the HP universal driver on the network pcs or use some other driver like the good old HPLJ5.

Collapse -

Not a network problem, a 1018 problem

by ferdia In reply to Shared Printer Spooler Lo ...
Collapse -

Same issue with Color Laserjet 2600n

by joe In reply to Not a network problem, a ...

We are running a 2003 Windows print server, and we have the exact same issue, but only with this printer. Out of the 53 (45 are HP) we have, it's the only one with the issue. And only NON-Domain Admin accounts experience the issue. Reset print spooler on the server, the user's jobs print, everytime. They print again, queue hangs, and no one can print, not even Admins, until the print spooler is restarted. I changed to an HP 4 driver as a test, and it worked. We tried HP's latest 2600n driver and an old 2600n driver that WAS working, but it's no help. I'm not ruling out a JetDirect issue either. Just when I think I have it nailed, something else calls in a question. The printer's JetDirect web interface is also an issue: no matter who sets a password, it will only require the password once. Connect from a different computer, and it allows any user to modify any settings without a password. That can't be normal.

Collapse -

i met same problem. (HP 1022n)

by webcup In reply to Shared Printer Spooler Lo ...

same with your problem.....

Collapse -

Need to restart print spooler everytime

by leon.matthasen In reply to i met same problem. (HP 1 ...

I have a shared printer, locally the print works fine, but as soon as somebody prints to the printer via network. the queue freezes, and you need to restart the print spooler, and it prints fine until somebody prints via network again. Os XP, Printer HP Color Laserjet 1600. Reinstalled printer drivers. still the same problem. Can anyone help. Will reinstalling XPsp2 help?

Collapse -

Had same issue....

by tim In reply to i met same problem. (HP 1 ...

We fixed this by using an HP 6L driver. No problems printing. Give that driver a try.

Collapse -

problem with shared 1018 printer

by soodeh_fazli In reply to Shared Printer Spooler Lo ...

I had the same problem.
i solved it with make my firewall off.

note:firewall on printer owner's pc

Related Discussions

Related Forums