General discussion

Locked

Sharepoint companyweb access problems

By trinianouk ·
Hi,

I have a new windows 2003 SBS with Sharepoint services installed. On the server I can access the companyweb default sharepoint site http://companyweb/default.aspx.

The problem occurs if I click on "Create" or Site Settings" or "Document and Lists". A logon dialog box appears requesting username and password. No matter what username and password I enter(Administrator does not work either) I cannot access the next page. I get an error for example:

http://company web/_layouts/1033/settings.aspx
Server Error in '/_Layouts' Application
Runtime Error.

I am logged in with Administrative rights and am a member of "Sharepoint Administrators group' in Active directory,
I have also added myself to the Website users under Sharepoint Central Administrator...still no change.

What am I missing here???
Any help greatly appreciated.
Jason.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CG IT In reply to Sharepoint companyweb acc ...

IIS

Sharepoint runs under IIS as a web site just as any other web site. Check the authentication requirements under the web site.

Collapse -

by trinianouk In reply to Sharepoint companyweb acc ...

My authentication method in IIS is set to "Integrated Windows authentication " only.

Anonymous login is off.

I tried turning that on and trying again...didn't work.Any more ideas???

Collapse -

by NZ_Justice In reply to Sharepoint companyweb acc ...

It sounds like you don't have permissions to perform the "Create" tasks, add yourself to the "Administrators" Site group. If you have changed your password recently this to can effect your login as well. If you made changes on the server involving Sharepoint a recommend you reset iis. You could also just reset iis and see if that helps you any.

Collapse -

by ITadmin In reply to Sharepoint companyweb acc ...

I have exactly the same problem apart from I changed my password and now have forgotten it!!

I have tried reinstalling companyweb but still my administrator username and password wont work.

If anyone could help it would be much appreciated.

Thanks alot.

Collapse -

Slightly Different problem but still same results

by hendrik In reply to

From my Server I can Access the company Web but from the user site with the very first page it requires authentication, where none of the usernames and passwords work. I have the same config as the others, but the weird thing is that Firefox can login no problem, but i experience the problem with IE7 and IE6.

Collapse -

Solved My Authentication Problem

by hendrik In reply to Slightly Different proble ...

I Created a new Virtual Server in IIS and created a new Top Level site with NTLM authentication. Backed up my current site with smigrate and Restored to new Virtual Server Location. Gave all the users access and it worked 100% with Firefox and IE6 & IE7

Collapse -

This solution worked for me

by frank In reply to Sharepoint companyweb acc ...

Turn on full asp.net error messages by changing the line in the web.config file at:

C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\TEMPLATE\ADMIN\1033\

from
<customErrors mode="On" />
to
<customErrors mode="Off" />

Browse the website again.
It should tell you the error was that it cannot write to the .NET framework temporary directory, and give you the path to it.
(If it tells you a different error, you'll have to find a different solution)

Go to this directory in windows explorer and give read,write,execute,list directory permissions to the local IIS worker process group (not the domain one), usually called IIS_WPG

Now it should work.

Back to Windows Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums