General discussion

Locked

sharing a folder with Everone group

By northwood ·
While logged in on XP as administrator, I shared a folder and added the Everyone Group. Now, remote users get a log on screen when they try to browse to my shared folder.

How do I share a folder so that Everyone access it through My Network Places and not have to enter in a Name and Password. I thought that Everyone group would eliminate the requirement to enter a n user name and password

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CG IT In reply to sharing a folder with Eve ...

welp, which one are you working with file/folder permissions, Active Directory domain environment with NTFS permissions or a workgroup setting with NTFS permissions?

Further define remote users. In a network environment, remote users are those who access the network from outside the network such as from the internet. Some use the term remote users meaning another computer on the LAN.

Collapse -

by northwood In reply to

Poster rated this answer.

Collapse -

by northwood In reply to sharing a folder with Eve ...

Thanks for your response.

This is a Work Group, no Active Directory.

Remote user is another user on the same LAN and same workgroup.

Hope that clarifies it.

Collapse -

by CG IT In reply to sharing a folder with Eve ...

where, there could be a couple of different issues going on. in a workgroup there are 3 main things that need to be present. 1. all computers belong to the same workgroup [and not the default workgroup setup during installation. you have to join the computer to a new workgroup even if the name is workgroup]2. user accounts must be present on all computers which will shared folders or files within folders. Example: If Jim shares a folder on his compuer for John, Johns user account must be on Jims computer.3. Ya have to share something.

There is also a security policy "access this computer from the network" in the local machine security policies. sometimes this gets changed by people who think deleting users or groups from it secures their computer. Such changes often times causes a lot of problems. Here an article: http://support.microsoft.com/default.aspx?kbid=823659

In XP unlike W2K, there is local sharing, network sharing and configuring the Windows Firewall to allow the folder to be shared with others on the network. If you right click a folder and choose sharing the folder properties windows will open to the sharing tab. To allow others on the network to access the shared folder you have to check the box in Network sharing and security. Just dragging a folder to the Windows XP All Users shared folder allows only local machine sharing.

Collapse -

by CG IT In reply to

Note: There was a discussion in TechRepublic discussions about the issue that users want admin privileges on their local machine. Granting users admin rights to the local machine allows them the ability to change the local machine security policy "access this computer on the network". Like the article referenced above, this can have really bad effect on networked computers if the users don't know what they are doing. Often times after mucking around, they can't access shared folders, blah blah and call up the help desk to fix it. Whats really happened is they were pissed at John or Jane and wanted to shut them out so they changed the access this computer on the network security settings.

Collapse -

by northwood In reply to

Poster rated this answer.

Collapse -

by InXale In reply to sharing a folder with Eve ...

Hi , there is a difference between shared permissions and NTFS permissions. Believe you might be using shared permissions. Go to the security tab and see if the everyone group is there with the correct permissions.

Rgds

Collapse -

by northwood In reply to

Poster rated this answer.

Collapse -

by Blackcurrant In reply to sharing a folder with Eve ...

Hi

I have been experimenting with this recently and discovered that you need to create an account on your machine with the share that is identical to the account that person logs on with at the remote machine.

So if Joe logs on at home as AdminMan and uses password xxxxxx you need to create exactly the same account and password on your router to get through it's firewall (if you have one), and create exactly the same account and password on the machine with the share. Because I also use a domain, I had to create a domain account using the same criteria. Only then were remote users allowed to access the resources they had permission to access - otherwise they were locked out of everything.

Good luck

Collapse -

by northwood In reply to

Poster rated this answer.

Back to Windows Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums