General discussion


sharing an external drive..

By pitbull1 ·
Once again I am back searching for your group's wisdom. To update, I had posted in the past about going with an external drive for backup and file sharing. Well I finally got an WD external USB drive and now have it connected to my main computer(it works fine there), but I am having difficulty setting it up to share with my laptop. I set the WD drive to be shared on the main PC, and if I go to My Network Places on the laptop, I can see the drive, along with the other folders I have shared amongst the two computers. If I double click any of the folders, I can access the files within them; but when I double click the drive I come up with the dialog box....
(name of drive) is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permission.
Not enough server storage is available to process this command.

Please help. Can somebody walk me through setting this drive properly to share with both computers?
Thank You,

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by echiasson In reply to sharing an external drive ...

Try making a folder in the USB Drive , and share that folder out and see if you can get to that , You might have to work in a Sub folder of the drive , instead of trying to share a whole drive letter out ,

Collapse -

by Nilt In reply to sharing an external drive ...

This happens a lot, actually. If you've disabled Simple File Sharing then there are two areas which need permissions set. You have to set permissions on the Sharing tab as well as the Security tab of the shared location.

The Sharing tab is for network access but then the NTFS permissions kick in if they're more restrictive and dny access in precisely this manner. Send me a PM and I will shoot you a one page PDF I made for my clients with exact steps. I'd post them here but they're a bit lengthy.

Collapse -

by tanselmo In reply to sharing an external drive ...

Hi Mark, I had the exact same problem. You need to make a change to registry on the PC that has the external USB drive. If you go to the event viewer on the PC that has the USB drive, you will see the same error message that you are seeing on the other pc that is trying to attach to the USB drive. Start the registry editor on the pc that has the usb drive (regedit.exe)
Move to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
Double click on IrpStackSize (Add IrpStackSize it if it is not there, case matters.)
Set the type to decimal and enter 50. Click OK Close the registry editor. You might be able to get it to work with a value less than 50, experiment a bit.
Let me know if this worksfor ya.

Collapse -

by tanselmo In reply to

Oops I forgot to mention that you must restart the server service, or reboot after making the registry change.

Collapse -

Hi Mark, same problem with new USB 250GB Seagate External

by dddap In reply to

Your valuable advice seems to have solved my problem. A BIG thank you !!!

Collapse -


by info In reply to

Thank you tanselmo! The IRPStackSize fix worked like a charm and I can now use my external HD for backing up again (btw it is a 250 gig Seagate as well if that means anything).

Here is a more detailed explanation of IRPStackSize from Microsoft and how to set it up/tweak it:

Collapse -

by aronp In reply to

i had the same problem and you helped me

Collapse -

It worked. Thanks.

by spider2003 In reply to

It worked. Thanks.

Collapse -


by wesley.chin In reply to sharing an external drive ...

Do you have sharing enabled on the main computer and laptop? I have only come across that message when something that is to be shared becomes unshared.

Related Discussions

Related Forums