General discussion

Locked

Sharing problem

By tech_soul7 ·
When I share a folder members of workgroup cannot access it. They open My network places click on view workgroup computers and when they try to access my computer (danijel) from network to see shared files and folders they got error message "Access is denied" or they are prompted to type in user name and password. Sharing and Ntfs permissions are set to full control for everyone. I tryed to switch to simple file sharing but it didn't helped. Where's the problem? Thanks

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CG IT In reply to Sharing problem

other computers have to be members of the same workgroup. A "workgroup" is akin to a security boundry. only those computers in the workgroup and only those files or folders that are shared can be accessed unless one uses the administrative shares providing administrator credentials.

Collapse -

by CG IT In reply to

well, I'll add this because most comsumers make this mistake. Windows creates a workgroup called "workgroup" when it's installed. Every Windows installation does this. Now, when you try to network some computer together, you have to create a new workgroup and join them to it. Just because they all have the same workgroup name "workgroup" [or MSHome with XP Home] doesn't mean they all belong to the same workgroup. They all have to belong to the same workgroup which means you have to join them to the workgroup. If you already did that ok, sorry for the epistle, but that mistake happens a lot.

Collapse -

by tech_soul7 In reply to Sharing problem

Yes they are all members of the same workgroup.

Collapse -

by HAL 9000 Moderator In reply to Sharing problem

Well in that case you'll need to go into your User Profile and make your Documents available to every one by changing the setting from Make the Files Private or whatever it says.

By the way you can add comments to your question you don't need to reply to it through the Answer Option if you need to add any more info just click on the Comments tab.

Col

Collapse -

by tech_soul7 In reply to Sharing problem

The name of workgroup is "Sroki" so that is not a problem. Everything works fine (for example multiplayer games, lan chat etc.) except sharing files and folders.
There are four computers workgrouped and shares are accessible only on one of them. What can lead to this problem? Could it be maybe some service which is stopped (server service is running) or could it cause the guest account which is disabled. If it is the guest account how can I have it disabled and still be able to share files and folders. Thanks

Collapse -

by CG IT In reply to Sharing problem

ok, sorry for that long epistle of workgroups but it's a common mistake.

check your share permissions.

though not necessarily needed, put the user accounts which will require access to share on every computer that hosts the share. If you run Windows firewall, add the local subnet to the trusted zone.

verify that local sharing is enabled on all computers.

Collapse -

by CG IT In reply to

just the same user name and password.

Another thing to check is NetBIOS over TCP/IP. to locate other computers on the LAN NetBIOS over TCP/IP needs to be enabled.

Here's a link about NetBIOS over TCP/IP for file sharing

http://support.microsoft.com/kb/318030/en-us

Here's a link on simple file sharing on XP

http://support.microsoft.com/kb/304040/

There is an 8 part series of setting up a Small Office workgroup on Windows XP Home. It's a pretty good series to get an understanding of setting up and troubleshooting workgroups. Tedious reading but gets into the nitty gritty things.

Here's the link for part 1 of 8 parts:

http://support.microsoft.com/kb/813936/en-us

Collapse -

by tech_soul7 In reply to Sharing problem

I think it's not problem with share permissions becouse I set for everyone to have full control.
Firewall is disabled.
You said "though not necessarily needed, put the user accounts which will require access to share on every computer that hosts the share" How can I do that?

Collapse -

by curlergirl In reply to Sharing problem

When using NTFS and share permissions in a workgroup, each user still has to have an account on the computer to access it. In other words, in order to be in the "Everyone" group, each user has to have a local user account on that computer. If you are not worried about some unauthorized person gaining access to your files and want to make it simple, you can create one local user account with a simple user name and password which everyone in the workgroup can use. To do this, go to Control Panel/Administrative Tools/Computer Management. Expand the System Tools folder; expand Local Users and Groups; right-click Users and click New User. Create your new user account, which will automatically be a member of the Everyone group. Now, when the other members of your workgroup try to access your shared folder(s), they will get a logon box. They type in the common user ID and password, and they will have access. If you want to set this up in a more secure way and at the same time make it easy for everyone in the workgroup, you can give each person their own user name and password on your computer rather than using a common one. As long as you use the same user name and password for each person that they use on their own workstation, they will not have to long in to your workstation to access your shared files. You just have to be sure that if they change their password, you change it also on your machine.

Hope this helps!

Collapse -

by curlergirl In reply to

Correction - "they will not have to log in" not "long in".

Back to Networks Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums