Question

Locked

Slave drive access is denied after master drive re-installation - XP

By aknon ·
My master (C:) drive recently crashed and I have to reformat and reinstall the XP OS. Now, my slave drive (a separate hard disk) is not accessible: "Access is denied".

My 20 GB slave drive is using the NTFS file system and there are about 6 GB of data that I cannot afford to lose.

Is there any way I can recover the data or, better yet, make the slave drive accessible?

Thanks.

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

This is normal and...

by TechExec2 In reply to Slave drive access is den ...

This is normal and you should be able to restore access. You need to have the new system "take ownership" of the files on your slave drive. This article explains how to do this:

How to take ownership of a file or folder in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;308421

-----

Note: If you used NTFS encryption, this will also apply:

Methods for Recovering Encrypted Data Files
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q255742

-----

Tip of the hat to "HAL 9000".

Collapse -

Thanks for the info

by aknon In reply to This is normal and...

Hi! TechExec2,
I have managed to solve the slave drive access problem with the info taken from the link you have supplied.

Thank you very much.

Collapse -

You're welcome!!!

by TechExec2 In reply to Thanks for the info
Collapse -

Almost the same problem

by d.leduc In reply to This is normal and...

I have almost the same problem. If it was the same problem I'd already have my answer.

I have a computer running W2K with two IDE hard drives setup as master and slave. The slave drive is dynamic with only one volume. The master drive went bad and was replaced and reimaged from a generic system image. The slave drive now appears is system hardware and in disk management as dynamic and foreign. I've seen all kinds of articles that suggest that I should rescan then right-click and import foreign. Unfortunately that is not a choice on any menu that I've been able to find. I can only revert to basic, or look at properties and that doesn't help. Is there some command-line way that I can import foreign or is there some other way to get this disk visible to the rest of Windows 2000?

Collapse -

Would Import Foreign Disk work?

by multiplexed In reply to Slave drive access is den ...

I'm not sure, but an easier way might be to go to computer management\disk management and right click the slave drive. Then select import foreign disk.

Collapse -

Import Foreign Disk - Dynamic Disks only?

by TechExec2 In reply to Would Import Foreign Disk ...

I have never used "Import Foreign Disk". But, I think it applies to dynamic disks only (1).


REFERENCES

(1) Troubleshooting
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sag_disktrouble.mspx?mfr=true

(2) Disk status descriptions
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/dm_status_disk.mspx?mfr=true

(3) To move disks to another computer
"If the disks are dynamic disks, Disk Management displays Import Foreign Disks dialog box. Right-click any disk marked Foreign, click Import Foreign Disks, and then follow the instructions on your screen."
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/dm_status_disk.mspx?mfr=true

Collapse -

Thanks for the help

by aknon In reply to Would Import Foreign Disk ...

Hi! Multiplexed,

I have tried the method you suggested, but I could not find the feature to "import foreign disk".

But I was able to resolve the problem by reading up on the link provided by TechExec2.

Thanks anyway for your assistance.

Collapse -

Same Problem

by btyler02 In reply to Slave drive access is den ...

I have a very similar problem. I reinstalled XP on my master drive which is SATA, but after the install when i connected my IDE drive, the BIOS and windows see the drive, but it has no assigned letter or way to access the contents on it. I have tried to use the Disk Manager, but it will not let me assign the drive a letter and when I tried the safe mode thing, it wouldn't let me go to the properties their either. The only options it gives me are to Reformat the drive or disconnect it? I can't afford to loose this info, and the whole reason I backed up everything was to avoid this situation? Any help is greatly appreciated!

Collapse -

No. Your problem is entirely different.

by TechExec2 In reply to Same Problem

Your problem is that the volume is not being mounted. This is entirely different that aknon's problem where the volume was mounted but access was rejected because the new system needed to take ownership of the files.

First of all, there is no "master" and "slave" with SATA. All drives are "master", one drive per cable.

Secondly, you refer to the PATA drive as "slave". If it is the only drive on the PATA IDE cable, it should be jumpered as "master". Or, it can be jumpered as "CS" (cable select) and be at the END of the cable, if the cable is an 80-wire IDE cable.

Third, is the SATA drive new to the system? Did you previously boot from the PATA drive?

I am suspicious that something bad might have happened to the PATA drive, or the data on it, while you were manipulating things. If Disk Manager can see the PATA drive, but does not show a partition on it (no NTFS or FAT partition), there may be something wrong with the drive.

Collapse -

I give up!

by btyler02 In reply to No. Your problem is entir ...

I installed the SATA drive for the clean wipe and installed XP on it. Then after a boot into the new install I shutdown and plugged in the IDE drive with all my backup data on it. I unplugged it so I wouldnt possibly be able to loose the info? So much for that. So after the next boot windows recognized the drive and all, but it won't mount. I can see it in the Disk Management program, but the only option I have is to delete the partition. It shows the drive as Disk 0, 128.00 as NTFS Helthy(Active), then another partition of the unused space as 21.05 GB Unallocated. I am dumbfounded. I have tried mounting it as my external, no luck, tried it on my other computer, no luck? What gives?

Back to Hardware Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums