General discussion

  • Creator
    Topic
  • #2248473

    Slave drive not showing in W.E.

    Locked

    by d.h. cesare ·

    I just installed an 80G WD slave drive in my WinXP Pro machine. The drive shows up in the SETUP screen, it shows up in Device Manager and it shows that it is working properly, but it does not show in Windows Explorer. I uninstalled & reinstalled the drivers but that didn’t fix the problem. The drive still shows to be working properly.
    How can I get the drive to show in WE?
    Thanx

All Comments

  • Author
    Replies
    • #3139173

      I’ve often seen this problem, it usually goes away

      by deadly ernest ·

      In reply to Slave drive not showing in W.E.

      once the drive is formatted in a format recognised by that version of WE.

      Sometimes, putting it in as the secondary master will also fix the problem.

      • #3139132

        How to format…..

        by d.h. cesare ·

        In reply to I’ve often seen this problem, it usually goes away

        How can I format it if I don’t know the drive letter designation? “C” is primary, “D” is
        CD-ROM, “E” is CD/DVD-RW. I would format it if I knew how to get at it.

        • #3141350

          Ever heard of Disk Manager?

          by why me worry? ·

          In reply to How to format…..

          this isn’t Windows 95 or DOS

          you need to partition the drive first and then format it

          right click on My Computer and select “manage” from the menu

          go to the disk management and you will see the new drive there

          partition the new drive as primary and format it using NTFS with default cluster size

          you can then change the drive letter if you wish after the format

    • #3139172

      Did you format the new drive?

      by techexec2 ·

      In reply to Slave drive not showing in W.E.

      Did you format the new drive? After physically installing a new drive, you must format it (put a file system on it like NTFS or FAT).

      STEPS

      1. Start->Control Panel->Administrative Tools->Computer Management

      2. Computer Management->Storage->Disk Management

      3. Locate your new 80 GB drive. WARNING: Be sure not to format your existing C: drive.

      4. Select the new unformatted drive (click on it). Choose Action->All Tasks->Format.

      5. I recommend you format your new drive with the NTFS file system.

      Post back and let me know how it went.

      • #3139156

        Agree – Even if the drive states

        by lodai ·

        In reply to Did you format the new drive?

        that it has been formatted. Most new drives require to be re-initialized (formatted) in order for them to be “seen” in WE.

        • #3139105

          Initialized

          by d.h. cesare ·

          In reply to Agree – Even if the drive states

          I was able to “Initialize” the drive, but can not find a way to format it because it is unallocated. I do have a screen that wants to create a “simple” volume on that drive, but I am not sure exactly what that means. It’s in the same place in the Disk Management screen that FORMAT should be.

        • #3139095

          FORMATTED !!

          by d.h. cesare ·

          In reply to Agree – Even if the drive states

          Finally found the format command in the “New Volume” Wizard. I want to thank everyone for their help.
          Have a good one.

      • #3139128

        no format available

        by d.h. cesare ·

        In reply to Did you format the new drive?

        After I’ve gotten to “All Tasks”, format is not an option. “New Volume” is one option and Properties is the other. When I click on
        New Volume, I get one option ->Simple. There are 5 types of volumes: simple, spanned, striped, mirrored and RAID-5. My only option is SIMPLE. I’m reluctant to go any further as I do not know exactly what’s going to happen, so the machine is setting here with the New Volume Wizard staring at me.

        • #3139122

          Re: No Format Available

          by the ice man ·

          In reply to no format available

          Since you do not have format as an option the drive is telling you it’s ready for a “volume” to be placed on the disk. Just create a volume it will then ask what type of volume it will be; simple – ie on a single disk, spanned on 2 or more disks for redundancy, striped similar to spanned but permits slight faster access of the data on the disk. Next will be which disk you want it on and how large of a volume to create (think of this as partions on the drive). Next will be asked for the drive letter to assign if any and the format of the drive/volume, ie fat, fat32, ntfs. Once the volume is created it will then begin formatting it, when done formatting it will show up in WE.

        • #3139066

          Got it

          by d.h. cesare ·

          In reply to Re: No Format Available

          Thank all of you for your guidance, especially TechExec2 for getting me started in the right direction. Everyone was very helpful.

        • #3139117

          Keep going…

          by techexec2 ·

          In reply to no format available

          Keep going. You’re doing exactly the right thing. Use the wizard to create a “simple” volume. The New Volume Wizard will also format the volume for you.

          Post back with success or if you need more help.

    • #3139106

      Partition and format from outside Windows

      by kiltie ·

      In reply to Slave drive not showing in W.E.

      That would be the way I would tackle the problem.

      You could use a 98 style start up floppy, or similar floppy based solution, all it needs is FDISK and FORMAT commands. If no floppy drive is available, there are bootable CD images of the same thing.

      Or

      Use a partition utility available from a Linux LiveCD, Hiren Boot CD, Ultimate Boot CD. There may also be other alternatives (Bart PE?? – not sure), but the main point is to do all this outside of your normal Windows OS.

      Once formatted, reboot to Windows and Explorer should now see it.

      CAVEAT: be very, very careful which drive you partition and format, to be safe DISCONNECT all hard drives except this one.

      Shouldn’t this question be in Tech Q&A?

      • #3139091

        Kiltie: This was “Windows 1A: Introduction to Windows”

        by techexec2 ·

        In reply to Partition and format from outside Windows

        This was “Windows 1A: Introduction to Windows”.

        Linux boot CD? That’s upper division stuff! 😉

    • #3139103

      Try this:

      by dawgit ·

      In reply to Slave drive not showing in W.E.

      Assuming WinXP, (or Win2k) Go to (your) “Administrative Tools”, (should be either under ‘Start’ or ‘Start\All Programs’), There you will see “Computer Management” Click on that and you’ll see a new panel. Once there go down to “Storage” and then to “Disk Management”. When you click on that a panel will show you all yoour drives. Click on your new drive and you’ll find the options to asign a dirve letter, as well as to partition it also. Be sure to mark it ‘active’ too. Piece of cake. -d

      • #3138974

        Never mark a drive ‘active’ except the boot drive

        by deadly ernest ·

        In reply to Try this:

        the active marking is the way to tell the system that it is the boot drive, and the system will look to its MBR for the directions. Do this to a slave drive and it will often cause the real boot drive to lose its ‘active’ setting and you can’t boot when it next restarts.

        • #3140331

          now that would explain….

          by dawgit ·

          In reply to Never mark a drive ‘active’ except the boot drive

          some strange behavior. ;\ You are correct, but there have been times when I had to mark one active, to get full access to it to do what I wanted to do. Yes, I had forgoten to mention un-activating it afterwards. (before the next boot). There is one machine I have that has two seperate drives as active, But I had forgotten the extra work I had to do to prevent the problems you describe. (Drive 1 has OS, drive 2 has a program that drive 1 uses, but runs on drive 2. -don’t ask, it just works)

        • #3140285

          This is a common event that comes about by

          by deadly ernest ·

          In reply to now that would explain….

          loading the operating system on one drive, then replacing it with one on another. Lets identify the drives in the following manner – in this example I’m using my system that has two IDE and two SATA channels:

          IDE Primary master = IPM
          IDE Primary slave = IPS
          IDE Secondary master = ISM
          IDE Secondary slave = ISS
          SATA Primary = S1
          SATA Secondary = S2

          Assume I have hard drives in all (hey I got plenty of USB for DVDs)

          I’m set the system up with Win2K on IPM, then dual boot with XP on IPS. Active is IPM, when I get around to blowing away W2K, the MBR of IPM will still be the boot drive, with the OS on IPS.

          Now I install S1 and load Linux, in the process I make it the active drive and have its MBR load the boot file. I install S2 and load UNIX, leaving the MBR on S1 as the boot. I go crazy and delete, Linux and Unix, settling for just XP as the OS. Active boot system is now S1 with the OS still on IPS.

          This situation usually occurs when you dual boot with an OS on two different physical drives, and delete the first loaded OS. Or you have a major issue with the OS, and reload a clean install on the second drive. The first still retains the MBR and active designation.

          Older system insisted that the active drive had to be the master, new systems you can set any drive as the active.

        • #3140221

          you wouldn’t try’n to..

          by dawgit ·

          In reply to This is a common event that comes about by

          confuse me with that now would you? (I’ve seen that done though, what a mess) Actually, I have two seperate OSs, (one on disk ‘C’, and the other on disk ‘D’) a couple of programs that I use are on disc ‘D’, which is a complete OS (for diasters, can be used as main OS). For those silly licenceing reasons, I only have those ‘installed’ once. When I want to ultilize one I do so off that HD. (‘C’ is the operating OS, ‘D’ has the software running.) I know, text books say it don’t (can’t) work. (oh, well) -d

        • #3140164

          I don’t know what text books you read, but

          by deadly ernest ·

          In reply to you wouldn’t try’n to..

          at one time the recommended method for best performance was to have the operating system on one physical hard drive ‘C’, the applications you sue on another physical hard drive ‘D’, the data and virtual memory (page file now) on a third physical hard drive ‘E’. Not physical drives, not partitions. This was because the biggest delay in the computer was the time taken by the hard drive to find the relevant bits of data, etc and feed it over the bus to the CPU. They couldn’t send and seek to the same drive. So if it was all on one hard drive, they took turns, on different ones then all three could be accessed by the cpu at the same time.

          Since then hard drive seek times have improved dramatically, and we’ve gone from 16 bit to 32 bit, and now 64 bit busses. they make a difference too.

          What you’ve detailed wont harm the system at all. it should even give higher security, safety and a slightly better performance.

        • #3140261

          Unactivating ??

          by d.h. cesare ·

          In reply to now that would explain….

          I do not know what/how to unactivate. The machine seems to boot with no problems. The drive shows as “Healthy”. Everything seems to be working the way it’s supposed to.

        • #3140225

          Good, don’t…

          by dawgit ·

          In reply to Unactivating ??

          change anything.!. :0 You have to excuse us old farts in this, sometimes we get a littled carried away doing un-norm things ;\ (to most users, anyway) B-)

        • #3140170

          If it’s a workin’ don’t go afixin’ it – you may bust it

          by deadly ernest ·

          In reply to Unactivating ??

          basic rule of staying alive. naturally the rule doesn’t apply to a working time bomb you wish to have stopped.

          if the system boots OK, then don’t worry. Some systems it can be an issue, but for many modern ones it isn’t.

          edited to fix typo in title that affected the meaning ‘do and don’t’ aren’t the same.

      • #3141280

        It’s so much easier

        by cely ·

        In reply to Try this:

        Just to alternate click on “my computer”, choose “manage” and then choose “disk management”. 😉

    • #3139021

      I know you got it working, but my question is

      by danlm ·

      In reply to Slave drive not showing in W.E.

      Did the new drive come with a cd? I only buy western digitalis, so I am unsure of other drives. But the Western Digital setup cd will format the drive for you outside of windows. Gives you partition options too.

      What type of drive was it?

      Dan

      • #3138964

        drive type

        by d.h. cesare ·

        In reply to I know you got it working, but my question is

        I use almost exclusively Western Digital. This one did not come with anything; no diskettes, no CD’s. Bare bones drive I bought last year and it’s just been sitting around waiting to be useful. Now that I know how to use the Computer Manager window a little, I won’t worry about the little things anymore. That procedure is slick and easy. Has to be easy for me to do it.

        • #3141277

          Download

          by cely ·

          In reply to drive type

          I use Maxtor discs myself and you can usually download the utility programs from their main site if you buy oem discs as I usually do. I would think you’ll find the same for WD.

        • #2488653

          i also used same

          by deepak_parajuli ·

          In reply to Download

          i also download some thing in my computer. if you want then i will give. my email address is deepak_parajuli@hotmail.com. and i want ur email address also.

    • #3140324

      You need to initialize it first in Disk Management

      by georgeou ·

      In reply to Slave drive not showing in W.E.

      Right click “My Computer” and hit “Manage”. Note that the “My Computer” shortcut does not work, you need to use desktop settings to reveal it to get to the manage option. Setting XP to classic view also shows this.

      Once you get in to “manage”, you go to “Disk Management”. From there, you can initialize a drive.

    • #3140230

      Go to drive management

      by w2ktechman ·

      In reply to Slave drive not showing in W.E.

      and partition/format the drive

    • #3140083

      ORIGINAL POSTER HAS SOLVED HIS PROBLEM

      by techexec2 ·

      In reply to Slave drive not showing in W.E.

      To save you from unnecessary effort…

      The original poster has solved his problem as noted here:

      http://techrepublic.com.com/5208-11183-0.html?forumID=89&threadID=201726&messageID=2102430

    • #3139984

      What I usually do in such a situation

      by eddie n ·

      In reply to Slave drive not showing in W.E.

      Assumption #1: the Slave drive actually does work, it has no defects or anything like that.

      Assumption #2: you don’t want to use the Secondary Master slot instead of the Primary Slave one for the drive (or you can’t use it, because the CD-ROM or whatever is occupying it).

      1. Power down the machine, take out the slave drive, and make sure that the data cable is placed in the right orientation, that the power cable is plugged in it, and (most especially) that the jumpers are set properly. If you have the jumpers set for Master and yet the drive is meant to be a Slave, there’s going to be trouble.

      Plug it all back. Power on the machine. Then,

      2. whether the drive shows up in Device Manager or not (and assuming you haven’t put anything on the Slave drive yet), use Windows to re-partition and re-format the drive. Since you are using Windows XP Pro, make sure that you format the drive using NTFS.

      Reboot the machine. The problem should be solved. However, if it still doesn’t recognize the drive in Windows Explorer, then

      3. Go to Device Manager. Remove the drive from the list, then press F5 or click the “Check for new Plug-and-Play hardware” button on the toolbar. Device Manager will probably show a couple of Taskbar balloons as it finds the new hardware, etc. (You may have to reboot the machine at this point, but not usually.)

      Now, go to Windows Explorer. It should be visible now. If it still cannot be seen in Windows Explorer, then either

      4a. Press the F5 key to refresh the display,

      or

      4b. Just type in the drive letter of the Slave drive in the address bar, followed by a colon, and then hit Enter. You may be surprised that it will show up then.

      Now, if after all of this, it STILL hasn’t shown up in Windows Explorer, you may have to call in the Ghostbusters 🙂

      • #3141275

        LOL

        by cely ·

        In reply to What I usually do in such a situation

        “Now, if after all of this, it STILL hasn’t shown up in Windows Explorer, you may have to call in the Ghostbusters.”

        Go on, admit it, you only typed all that just so you could get the punchline in! 🙂

    • #3281241

      how to check it

      by rahmat5101030 ·

      In reply to Slave drive not showing in W.E.

      my harddisk mas deteck in my BIOS but after we enter to windows….the drive wasnt…we don’t know how to get it….please recomd

Viewing 9 reply threads