General discussion

Locked

slow AIX system

By flyingknees ·
Hello, is there any way for me to find out why my AIX system is so slow? I've tried running VMSTAT and IOSTAT but I'm not sure what I should look for? I'm getting a lot of calls from external users about this sluggishness and sometimes they get kicked off from their telnet sessions.

My output from VMSTAT is:
kthr: r=0, b=0
memory: avm=51713, fre=374
page: re=0, pi=0, po=0, fr=1, sr=7, cy=0
faults: in=185, sy=612, cs=96
cpu: us=5, sy=2, id=90, wa=3

for iostat:

tin=13.7
tout=1538.5
avg-cpu: %user=4.6, %sys=2.3, %idle=89.8, %iowait=3.3

any suggestions would be appreciated...

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by cpfeiffe In reply to slow AIX system

vmstat output:
CPU looks fine id=90 (90% idle)
faults are good (you will always have a few hundred, a few thousand is typically not good, but depends on what the system is doing. in or interrupt and cs or context switch should be lower than sy or system fault. You really don't want in to be a four digit number). Paging looks good. Kthr or kernel thread looks good. These (r and b) are processes that are in the run queue (should be < 4 * # of CPUs) and blocked processes (waiting on io). blocked processes should always be 0 in an ideal world, but every now and then it will go up a little. Free memory looks low. Try doing sync (maybe up to three times) on the command line and see if that changes this number. sync writes unused memory back to disk. If that does change this number to a significantly higher figure you are OK. If not, you are really using all of the RAM you have. Also just using vmstat without a count is no good. This is the average since boot time. Useless. What you really want to do is run vmstat 3 when there is a problem (will run every three seconds to show active results until stopped with ctrl-c. Again the first line of output is useless).

This is a good first indicator of problems. If nothing sticks out here you are typically OK on most hardware except disk and network. To check disk use iostat -d. Like vmstat run iostat -d 3.

Out of room. More to come in second submission.

Collapse -

by flyingknees In reply to

Poster rated this answer.

Collapse -

by cpfeiffe In reply to slow AIX system

I wanted to talk about networking as a possible problem also so here is the rest of my answer.

If all of this looks good you may want to look at the network. If you are connected to a switch/router get a network guy to verify your connection. You should show the same speed/mode on both ends. A lot of times people use auto negotiate and it doesn't work. If you are 100 half and the switch is 100 full or vice versa you will have serious problems. A sniffer should be able to detect this as well as you will see collisions. Maybe the problem is further down the line between to switch inter connects or even on the users' PCs. Depending on what equipment you are using and how speed/mode is set at your site this may be a serious problem. Most people don't believe it (say auto negotiate always works) but I've uncovered this issue time and time again. If you are taking collisions on either end then this is a likely scenario. Try an FTP of a 30 MB or bigger file from your server to another server on the same subnet and see how that goes to help isolate your problem. At 100 Mbps a 30 MB file should transfer in about 3 seconds. I would be happy with anything under 6 becuase network and server load has to factor in to. If you are getting much worse (like 15 seconds are more) then you likely have a serious networking problem.

Feel free to email my alias if you have any further questions. Good luck.

Collapse -

by flyingknees In reply to

Poster rated this answer.

Collapse -

by flyingknees In reply to slow AIX system

This question was closed by the author

Back to Linux Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums