General discussion


Slow logon to domain in XP Pro

By gregberry ·
Let me preface this by saying that I already looked at the article at

However, when I open the MMC and add the group policy snap-in, and drill down through Computer Configuration -> Administrative Templates -> System -> Logon, I do not see "Always wait for the network at computer startup and login" to change to enabled.

Should I be doing something different when I add the Group Policy Snap-In? Should I change it to Entire Domain, etc.

Also the article says to upgrade the standard policy template with the XP policy template. How do I do that?


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by sgt_shultz In reply to Slow logon to domain in X ...

does this point the way?
<snipped> from
search by article id mskb 305293
This article describes the Windows XP Professional Fast Logon Optimization feature.
By default in Windows XP Professional, the Fast Logon Optimization feature is set for both domain and workgroup members. As a result, Windows XP does not wait for the network to be fully initialized at startup and logon.
Note that Windows XP clients support Fast Logon Optimization in any domain environment. To turn off Fast Logon Optimization, you can use the following policy setting:
Computer Configuration\Administrative Templates\System\Logon\ Always wait for the network at computer startup and logon

When this policy is enabled, a Windows XP client behaves in the same manner as a Windows 2000 client at both system startup and at user logon.

Collapse -

by gregberry In reply to

No, already looked there.

I was looking for it on the server instead of the workstation.

Collapse -

by abailey101 In reply to Slow logon to domain in X ...

Is this the only WinXP system you have? Does this problem occur on other WinXP systems?
I ran into a simular issues when I installed our first XP systems and it was related to my DNS server. I had moved DHCP off of my W2K AD server to a Firewall/Router in order to share internet access. The firewall had its own DNS server. I had to add an entry in my W2K server to foward DNS requests to my firewall. The strange part is that any of the W98 or W2k PC's worked fine

Collapse -

by gregberry In reply to

I was looking for the policy on the server, not the workstation.

Collapse -

by gregberry In reply to Slow logon to domain in X ...

This question was closed by the author

Related Discussions

Related Forums