Small Business Server 2003 Dual NIC packet loss

By ian.nelson ·
I have recently upgraded a clients 2003 SBS with another network card so that they can have one public and one private interface in order to use the built in SBS2003 VPN and Outlook Web Access facilities properly.

The SBS server runs DNS and WINS services for the local domain. On single NIC configuration with a local IP address and ADSL router all works well, however as soon as the second card (An Intel PRO1000 PCIe with the latest driver from installed) is enabled and the "Connect to the Internet" wizard run, the SBS can only very intermittently ping an address on the Internet.

Broadband is through ZEN (a UK ISP) with a subnet of 8 public addresses - I have correctly configured the WAN address and router - this I have tested by giving one of the domain machines a public address and this works faultlessly.

It seems that it is only the local server which has the packet loss problem - as when setup as a dual NIC configuration client machines can route through the SBS server. I have tried everything I can think of but have had no success in sorting this intermittent local routing issue.

Can anyone help?!

An idea - could router MTU be the problem?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

TCP/IP properties

by Nimmo In reply to Small Business Server 200 ...

Firstly make sure your TCP/IP setting on each NIC are set correctly. Make sure that DHCP on the routers local interface is turned off and is correctly configured.

Run diagnostics on the router to make sure it isn't an issue with the WAN connection.

If none of the above are issues then try this it's normally used to fix the issues that occur with installing SP2 on a SBS box (not sure if you have done so) but I have recently had this issue occour with a couple of SBS box's that don't have SP2 installed.

Open device manager do a right click on the NIC's, select properties, and then choose the the "advanced" tab.

Look for something like "Large send offload" in the properties box change the value to "disable".

(note: when you perform this action you will temporally loose connectivity nothing to worry about it will come back lol, kinda scary if your doing it remotly though).

Now open regedit and browse to the following key:


Right click in the right hand task pane and select new DWORD and create the following keys with the associated values.


It does say you need to reboot but i'm pretty sure I didn't do a reboot straight away because they are production servers and I had to wait until no one was accessing it.

But if you can, do the reboot this should fix the problem you are describing.

Collapse -

If at first you dont......

by ian.nelson In reply to TCP/IP properties

Nimmo -

Excellent tip but unfortunately it hasn't worked. The server is doing exactly the same thing - not 100% packet loss but intermittent. I also tried a USB LAN interface with the same results (i.e. a LAN interface without the complexity of the Intel).

Any more ideas?

Collapse -

If I remember correctly there was an issue with

by CG IT In reply to Small Business Server 200 ...

Gigabit NICs on SBS 2003, sometime early 2008. To fix the problem, you disabled some of the NIC features. For the life of me I can't find the exact KB article on it, still looking for it ....

Ok found this on R2 Premium versions

Networking issues including NAT and VPN connectivity programs, Outlook not connecting, RPC errors, etc.:
RESOLUTION: Needs network card driver updates, and disabling of RSS and Checksum offload settings.

Collapse -

Checked those settings.....

by ian.nelson In reply to If I remember correctly t ...

...and they are alredy set. I have a copy of DRTCP on the server now and I'm going to try a few things with the MTU - the more I think about it the more likely is seems.

Have you any other suggestions?

Related Discussions

Related Forums