General discussion

Locked

SNAP Server FTP issue

By mgevans ·
I have a client with a SNAP appliance (model 2200 i believe) that sits behind a SOHO router on a Verizon Business DSL line. We have set up FTP on the SNAP server and inbound allowed access through the firewall.

It works great... except (isn't there always an exception??)...

There have been a couple of users that want to access this resource from home and have run into problems.
User 1 (Brian) uses Comcast at home. Brian cannot use his PC to connect to the above FTP site. We have tried the DOS ftp util, IE's built in FTP client, and SmartFTP. We get a connection reset message. Brian _CAN_ get to OTHER ftp sites without an issue (he can log into my web's FTP site for example). We tried this with and without his router in the mix. We've tried with and without Passive mode disabled.

User 2 (Kim) Kim works in a satellite office to the main office where the SNAP is located. Her office is on Verizon Business DSL. From her office anyone can reach the home SNAP FTP site. Since Kim is working from home for the next few months, Kim brought her PC home from the office. She uses Verizon DSL at home. Kim cannot use her work PC from home to connect to the above FTP site (even though it worked in the office). We have tried the DOS ftp util, IE's built in FTP client. We get a connection reset message. Kim _CAN_ get to OTHER ftp sites without an issue (she can log into my web's FTP site for example). Kim does not have a home router. Her other PC at her house also cannot get to the SNAP FTP site.

To summarize: Some people can connect remotely to the SNAP FTP site without issue. Some people cannot connect to the SNAP FTP site but they don't have issues connecting to other FTP sites.

I haven't been able to find anything obvious about the SNAP FTP software that would indicate that some inbound connections would not work. I'm really not sure why we are having this issue but it is becoming very frustrating...

TIA! Michael

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by dgarcia In reply to SNAP Server FTP issue

I am having the same problem. I can telnet to port 21, I can us 3rd party clients all day but many users are having problems connecting from various type of internet connections. I am looking into this more and will post since I need something now.

Collapse -

by pinco789 In reply to SNAP Server FTP issue

Hi,

FTP works in two modes: active or passive. When it is in "active mode" the client opens a TCP connection to the server (on a port decided by the server) to actually transfer the data, when it is in passive mode is the server opening a connection to a port on the client (decided by the server).

This means that if the server is behind a router doing NAT/PAT or a firewall passive mode does not work, if the client is behind a NAT/firewall then active mode does not work. If both are behind different NAT/firewalls... FTP just does not work.

In my experience SNAP servers use the port range 49152 to 65535 for passive mode, thus you might open on the firewall (or NAT) that TCP port range on the server's site and this might fix your problem.

Ciao,

A.

Back to Networks Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums