General discussion

Locked

Solaris - Can't mount my cdrom

By cp409sd ·
I just ran the JASS(Solaris Security Toolkit) on my Solaris 8 box to harden it. It stopped many services. Now I am unable to mount my cdrom drive. It used to mount automatically when a cd is placed in the drive, but now it does not.

I am underthe impression that this functionality was because vold was running. JASS renamed the /etc/vold.conf file to something else, but I have since renamed it to its original name. I have also re-enabled vold at startup, but this does not seem to help.
I have also tried to mount it manually, but have been unable to do so.

Actually, I really don't care that much about the automatic mounting of the drive. I want to be able to mount it using the mount command. I just can't seem to figure out my correct disk to mount it to and the right syntax to do it.

I have tried to mount my cdrom with the following syntax:

mount -F hsfs -o ro /dev/dsk/cxtxdxsx /cdrom

I have tried all of the disks on my system, which are:

# ls /dev/dsk
c0t0d0s0 c0t0d0s3 c0t0d0s6 c0t1d0s1 c0t1d0s4 c0t1d0s7 c0t2d0s2 c0t2d0s5
c0t0d0s1 c0t0d0s4 c0t0d0s7 c0t1d0s2 c0t1d0s5 c0t2d0s0 c0t2d0s3 c0t2d0s6
c0t0d0s2 c0t0d0s5 c0t1d0s0 c0t1d0s3 c0t1d0s6 c0t2d0s1 c0t2d0s4 c0t2d0s7


If someonecould tell me how to find the correct disk and the right syntax to mount it with, I would really appreciate it. Thanks.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Solaris - Can't mount my cdrom

by hberkhoff In reply to Solaris - Can't mount my ...

You could try the following :

If the Volume Manager is not running on your system, enter the following commands to mount the CD-ROM:

mkdir -p /cdrom/unnamed_cdrom

mount -F hsfs -o ro /dev/dsk/c0t6d0s2 /cdrom/unnamed_cdrom

(the -o andro text are on the same line)

where /cdrom/unnamed_cdrom represents the CD-ROM mount directory.

Collapse -

Solaris - Can't mount my cdrom

by cp409sd In reply to Solaris - Can't mount my ...

I have the directory /cdrom. I tried the following:

bash-2.03# mount -F hsfs -o ro /dev/dsk/c0t6d0s2 /cdrom/
mount: No such device
mount: cannot mount /dev/dsk/c0t6d0s2

It did not work. Thanks for the help though.

Collapse -

Solaris - Can't mount my cdrom

by 4horseman In reply to Solaris - Can't mount my ...

vi /kernel/drv/sd.conf
look for this: name="sd" class="scsi"
target=6 lun=0;

If it is not there you need to add it back.
Then reconfigure the kernel:
The new solaris command is: devfsadm
the old solaris command is: drvconfig;disks

then reboot your system using the reconfigure
switch just to make sure.

#reboot -- -r
ok boot -r

You should be back to a point you can mount the cdrom using the mount -F hsfs -o ro /dev/dsk/cxtxdxsx /cdrom

I hope this helps you out.

Collapse -

Solaris - Can't mount my cdrom

by schannachie In reply to Solaris - Can't mount my ...

Hi,

I've just read the two answers and to be shure
all is ok, first shutdown the JASS, so you can
be able to restrore the automount at it's
default state. Then mount the drives
automaticaly, when they are corrctly mounted, at
the command line execute the mount command and
you will get the physical device (floppy, cdrom,
etc), then you can activate the JASS again.

Hope it helps ...

Collapse -

by jo.liang In reply to Solaris - Can't mount my ...

try /etc/init.d/volmgt start

Back to Linux Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums