Question

Locked

Solaris machine is not coming up on reboot.

By eldhom ·
My Solaris 10 machine is not coming up on reboot, if I disable ipv4-forwarding and routing.

I have disabled the ipv4-forwarding and ipv4-routing by executing
1. routeadm -d ipv4-forwarding
2. routeadm -d ipv4-routing
3. routeadm -u
Now if I reboot the system, it is not coming up. Means I am not able to access remotely. I can only access directly.

Please help me to fix this.

Thanks & Regards,
Eldho

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Maybe!!!

by Mehul Bhai In reply to Solaris machine is not co ...

I don't know much about Solaris but I think the forwarding & routing may be required for the remote access!!!???

Collapse -

Describe your topology

by robo_dev In reply to Solaris machine is not co ...

when you say "access remotely", I would assume that your server has two interfaces...one for the LAN and the other for the WAN??

If there is a separate WAN interface, and the IP address of the server is on the LAN, then it would be necessary to route between the interfaces to establish a connection over the WAN interface.

Collapse -

Solution

by eldhom In reply to Solaris machine is not co ...

Hi All,
Thank you for your suggestion...
The issue is resolved.
The problem was "/etc/defaultrouter" was not configured with the default router's IP address. Once it is configured, the machine starts connecting from outside network remotely.

Collapse -

?????

by Mehul Bhai In reply to Solution

It seems you created the porblem and even solved it!!!??? That's what I meant in my previous post.

Collapse -

Hi Mehul

by eldhom In reply to ?????

It is not recommented to enable forwarding and routing in Solaris OS because of some security reasons.
If routing is enabled in Solaris machine, it will function like a router which is a threat. If routing is disabled it will look for the default router which should be configured in "/etc/defaultrouter".
This issue was reported by one of our customer and I was not aware of this file defaultrouter. I got this information from some site and it worked for me. So I just share with all of you.

Back to Windows Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums