General discussion

Locked

Solaris OK prompt auto boot disk0

By lcw ·
How to set my Sun Solaris system on the Ok prompt to auto boot my disk 0.Currently each time
it boot from the net or perharps set to default setting.
pls advise.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Solaris OK prompt auto boot disk0

by cpfeiffe In reply to Solaris OK prompt auto bo ...

printenv will show you all of you're current settings and the default. First you have to set autoboot to true with 'setenv auto-boot? true'. Then you have to look at your boot-device and make sure it is disk0. You can set it with 'setenv boot-device disk0'. This may get tricky as you may have to list the full scsi path or something, but try disk0 or just disk first. You may be lucky. That is all it should take. Good luck.

Collapse -

Solaris OK prompt auto boot disk0

by lcw In reply to Solaris OK prompt auto bo ...

The question was auto-closed by TechRepublic

Collapse -

Solaris OK prompt auto boot disk0

by ghislain.levesque In reply to Solaris OK prompt auto bo ...

By default it is suppose to boot from DISK. If you want to redefine it here is how to do it:
- first use the nvalias commande to define a new boot path, then set the auto-boot? and boot-device variable. :

to get the address of the disk do this first:
setenv auto-boot? false
reset
and once at the ok prompt, probe-scsi-all to get the exact address of the disk that you want to boot from... after type these command :
nvalias disk0 /pci@1f,4000/scsi@3/disk@a,0:a
setenv auto-boot? true
setenv boot-device disk0 disk
reset

This will define a new boot path know as disk0 and try to boot from disk0, if it doesn't work, it will boot from disk

hope this help

Collapse -

Solaris OK prompt auto boot disk0

by lcw In reply to Solaris OK prompt auto bo ...

The question was auto-closed by TechRepublic

Collapse -

Solaris OK prompt auto boot disk0

by IKinney In reply to Solaris OK prompt auto bo ...

You should just be able to go to the OK prompt and type:
setenv boot-device disk0 cdrom

This will first try to boot from your disk0 and if that doesn't work your cdrom.

Then type:
reset

This will reboot your machine with the new settings.

You can check the valid boot devices by typing "devalias" at the ok prompt.

Collapse -

Solaris OK prompt auto boot disk0

by lcw In reply to Solaris OK prompt auto bo ...

The question was auto-closed by TechRepublic

Collapse -

Solaris OK prompt auto boot disk0

by lcw In reply to Solaris OK prompt auto bo ...

This question was auto closed due to inactivity

Back to Linux Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums