Hardware

Question

something so wrong that it made memtest86 freeze

By halfbeing ·
Tags: Windows, Hardware
There is something so wrong with one of my computers that it made memtest86 freeze. The motherboard is an ASRock 980DE3/U3S3 with the latest BIOS. I am running Windows 10 version 20H2.

Last night I set memtest86 to work on the computer. It was going well for 5 hours before I turned the monitor off (the monitor is a TV, connected by HDMI, that I have to turn on and off using its remote control). I left it running overnight. This morning I turned the monitor on and saw that memtest86 had been running for nearly 14 hours, which was approximately the time since I had set it going. It had done 6 passes and found 0 faults. However, when I tried to terminate memtest86, it didn't respond to my keystrokes. It was then that I noticed that memtest86 was frozen apart from a blinking cursor. I presume that either turning on the monitor or entering a keystroke must have triggered the freeze.

The behaviour that led me to try running memtest86 is frequent blue screens, freezes, and other malfunctions, which have been going on for a few days. The first malfunction was when I woke the machine up from hibernate a few days ago and got a message telling me that the BIOS settings were corrupted and asking me if I wanted to return the settings to default, which I did.

I can't remember the precise error messages for the blue screens, but the last one was something to do with paging (if I remember correctly) and apparently is very likely due to RAM or disk defects. When I get a blue screen, that itself freezes. The core dump progress remains at 0%. The problems continued even after sfc /scannow detected and fixed some corruption. But clearly, if memtest86 can't run reliably, I must also have a hardware problem.

My guess is that the next step would be to re-flash the BIOS. The problem is that the machine is now so unstable that there is a not insignificant chance it would crash during the BIOS update, which I obviously don't want to happen. Therefore re-flashing the BIOS is kind of a last resort. Are there other possible causes of the instability that I could look at first before re-flashing the BIOS?
Thread display: Collapse - | Expand +

All Answers

Collapse -

Replaced CMOS battery.

by halfbeing In reply to something so wrong that i ...

Eventually I did take a chance and I flashed the BIOS. When I rebooted I got a CMOS checksum error. I then tested the CMOS battery with a multimeter and found that its potential difference was down to less than 0.5V. That is a bit odd because it must mean the battery had already been useless for a long time, even though the problems only started a few days ago. But I've changed the battery anyway. Presumably I will find out soon enough if this hasn't resolved the problem. One thing that does seem different now is that the first stage of booting (before the ASRock splash screen) is much less slow.

Collapse -

CMOS checksum.

by rproffitt Moderator In reply to Replaced CMOS battery.

Once the battery gets that low you often have to load defaults and save. But the age of the gear and other parts of the story are missing here so I can't guess if there are issues with fans, dried up heatsink compound or just aging PC issues.

Tell more.

Collapse -

CMOS checksum

by halfbeing In reply to CMOS checksum.

I think only time will tell. The computer ran for a few hours without incident after I had replaced the CMOS battery, but I wasn't doing anything with it. Once I get back to working on stuff I should know soon enough if there is still a problem. I refreshed the thermal compound just a few months ago.

Collapse -

My SSD needs replacing, but that doesn't explain memtest86 freezing

by halfbeing In reply to CMOS checksum.

It now looks like I may have multiple problems. I had another blue screen. The screen froze, but the system continued producing audio (ASIO) for a while before giving a blue screen with "unexpected store exception" as the error message. And also, as with all my recent blue screens, the core dump progress stayed at 0% and I had to force a shutdown. Apparently "unexpected store exception often indicates disk problems.

I ran chkdsk on the system SSD and found errors, so I obviously need to replace that. But that doesn't explain why memtest86 froze.

I have an ASRock 980DE/U3S3 motherboard with an FX-8350 processor and an Asus branded GT-610 graphics card.

Collapse -

Ouch.

by rproffitt Moderator In reply to My SSD needs replacing, b ...

That's a model that the shop would not take for service unless it's for a new motherboard etc. But what to try?

You did the CPU compound so it's time to:
1. Inspect for BAD CAPS.
2. Replace the compound on the bridge chips (motherboard.)
3. Replace the compound on the graphics card.

That system is not known to stand up to stand up to stress testing today. The best we can hope for is to keep it running without passing stress tests.

Related Discussions

Related Forums