General discussion

Locked

SP2 and email

By Blackcurrant ·
I have just installed Service Pack 2 for XP on a Dell Dimension 2400, P4 2.6GHz, 512MB RAM, 30GB free disk space. The workstation has been kept up to date using Microsoft's built in Automatic Updates feature.

After installing the service pack I have discovered that Pegasus Mail (I use the latest version) now takes 1min 30secs to open messages.

Pegasus is currently configured as follows:
c. 40 users in a single Active Directory domain. Pegasus' files located on the domain server (Dell Powerdege running Windows 2000 Server/Small
Business Server 2000). All references to the files on the server use UNC paths - \\servername\pmail.

I tried to open messages with the Windows Firewall disabled, and have also disabled Norton Antivirus. I have used other programs since
installing SP2, and have not experienced any problems using them.

I assume that the Windows Firewall is not an issue here as Pegasus Mail is actually receiving data from the server. I also added the executable to the firewall's exceptions list, just in case, but it still took the same amount of time to open a message.

I have contacted Pegasus Mail's Technical Support Team who say "Something about the SP2 upgrade broke the drive access. ...you need to talk to MS. The problem is not with the [Pegasus] program, the problem is with the OS changing the way things are done and some process got broken by this change."

I dare not push SP2 to all the other WinXP machines until this problem is solved. If anyone can help I will be extremely grateful.

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by sgt_shultz In reply to SP2 and email

well, maybe just make sure it is not something else besides sp2? does uninstalling sp2 fix things? what about spyware? does message open the same in safe mode? forgive question if pegasus mail is html..

Collapse -

by Blackcurrant In reply to

Hi sgt schultz, thanks for answering. Pegasus Mail was working fine before SP2 was installed. I do not have access to the machine until next monday, so will uninstall SP2 then, and see if Pegasus behaves any differently. However, I am pretty sure that SP2 is responsible for this changed behaviour.

I have checked the TCP/IP settings (fine), and have checked the Event Viewer ? no application errors, and no system errors, I am not prompted by a firewall alert. I have also run SFC to make sure the system files are OK. As far as I can tell, the machine is working as it should. Plus, all the other applications are working fine ? Office 2000, a CAD program, a LAN messenger program etc. If there was a problem with the system I would have expected these programs to have behaved differently as well. Generally, the systems where I work are in pretty good shape.

I was wondering if Pegasus Mail uses some non-standard way of accessing the server, and that the more stringent security and control over TCP is causing the delay when opening messages. The Microsoft article 'Changes to Functionality in Microsoft Windows XP Service Pack 2 Part2: Network Protection Technologies' describes how this takes place, but because I do not understand how Pegasus Mail communicates across the network, I do not know if this is relevant. I was rather hoping that the Tech Support staff would be able to clarify it when I mentioned it...

hmm, bit of a long reply, this. Anyway, the weekend is just starting...

Collapse -

by pawsprint In reply to SP2 and email

try this first before uninstalling SP2:

Backup your Pegasus messages and contact list
uninstall Pegasus
reboot, and reinstall Pegasus

~pawprint~

Collapse -

by Blackcurrant In reply to

Hi ~pawprint~, many thanks for answering. I tried your suggestion but it made no difference. Thanks anyway.

Collapse -

by montea7 In reply to SP2 and email

MS has enabled data execution prevention (DEP) with SP2. It is another security feature to help prevent buffer overflows. Try ....Control Panel...System....Advanced....Performance (Settings).....Data Execution Prevention...Turn on DEP for all except those I select....then Add Pegasus Mail as one excluded from DEP. If that does not work, then as a last resort try disabling DEP globally by editing the boot.ini and replacing Noexecute/Optin with Execute/Optin.
Disbaling globally should be viewd as a temporary fix until the problem program is fixed or updated to work correctly. Also, see this article for a little more explanation on how DEP works http://www.theinquirer.net/?article=17782

Collapse -

by Blackcurrant In reply to

Hi Montea, thanks for your reply. I tried adding Pegasus to the DEP exclusion list, and also tried rebooting with DEP disabled, but the program is still taking 1min 30sec to open messages. Thanks anyway.

Collapse -

by Blackcurrant In reply to SP2 and email

Hi sgt schultz. I uninstalled SP2 (after trying pawprint's suggestion), and ran Pegasus Mail - everything worked as it should.

Collapse -

by Blackcurrant In reply to SP2 and email

Point value changed by question poster.

Collapse -

by pierrejamme In reply to SP2 and email

Computer slowdown appears to be one of the maladies of SP2. Check out reports from various "Brave Souls" who have installed SP2 at:
http://www.informationweek.com/story/showArticle.jhtml?articleID=46200911

Collapse -

by Blackcurrant In reply to

Hi pierrejamme, I don't think the lengthy wait for a message to open is the result of a general system slow-down. The other programs are working as I would expect them to. Pegasus mail is the only program exhibiting this delay when opening a file.

Back to Windows Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums