General discussion

Locked

Spooler subsystem app has encountered a problem and needs to close

By tmiddlemas ·
I recently had to do a repair of a XP Home installation and ran the XP Home setup CD. All worked fine, but now as soon as a user logs on they are greeted with a "Spooler subsystem app has encountered a problem and needs to close" message, which continues to pop up periodically while the PC is running. Printers which were installed prior to the repair are no longer present in the printers and faxes window, and when I try to re-install a printer I get a message saying the "Print Spooler Service is not running" (however if i check in services it says it is) I have tried the MS knowledge base articles 810894 and 324757 also deleting and .shd and.spl files suggested in previous threads on this subject. But nothing makes any difference.
ANY help please!

This conversation is currently closed to new comments.

23 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

RE: Spooler issue

by DugaDugDug In reply to Spooler subsystem app has ...

This was an issue that was resolved with SP2. Install, or reinstall, XP SP2. To stop the message from occurring, should installing the latest SP not do the trick, go to the command prompt and type 'net stop spooler'

Collapse -

by tmiddlemas In reply to RE: Spooler issue

I can stop the print spooler eror message from ever popping up by disabling the print spooler in services. However I still cant install a new printer. Something during the XP refresh has caused this problem but Im at a loss exactly what! I will try installing SP 2 again.

Thanks for your help.

Collapse -

Problem Solved

by tmiddlemas In reply to

For anyone whos interested, I fixed this problem by running the XP installation disk again with all peripherals disconnected.

Thanks for helping

Collapse -

I have the same problem and one of the solutions is to run the XP disc

by drush In reply to Spooler subsystem app has ...

with all peripherals disconected but I don't have the original disc. What else might help.

Collapse -

Reinstall Windows XP SP2

by bhatnagar_nitin In reply to I have the same problem a ...

Goto this site and download the SP2 and run it from your local machine.
http://www.microsoft.com/downloads/details.aspx?FamilyId=049C9DBE-3B8E-4F30-8245-9E368D3CDB5A&displaylang=en
Reinstall it and you will be all set.

Collapse -

Possible issue is a file stuck in the print queue.

by p.messer In reply to I have the same problem a ...

I was getting the same error from an HP 1020 that had been working fine, no system changes had been made. (I have no reason to think this is strictly related to this model printer) I noticed that there was a file I had tried to print a few days ago stuck in the printer queue for that printer, about the time when first started seeing the spooler error. I could not 'cancel' that file from the queue. To fix, I unplugged the USB from the 1020, started the print spooler service manually (from run/services.msc), and then I could cancel the print job using the printer queue. So far so good...

Collapse -

HP 1020 was my issue

by LGentile In reply to Possible issue is a file ...

I just wanted to say THANKS for this one. I looked through a bunch of MS documentation and as usual, it led me to measures I didn't think I had to do (mess with registry settings, delete all printers, etc).

I killed the spooler service and all HP services in memory, then deleted all files in the spooler directory (Windows\System32\Spool) and I was then able to restart the spooler and print a test page to the 1020 printer.

Thanks again!

Collapse -

Same printer same issue,,,,thanks

by aarond1234 In reply to HP 1020 was my issue

Saved lots of work.

Collapse -

Spooler print Problem (on Windows Server 2003)

by ccarte70812 In reply to HP 1020 was my issue

I experienced the same problem, but on Windows Server 2003

I didn't feel comfortable deleting the files so I cut the files out of the spooler directory, and placed them in a temp directory. Restarted the spooler and tested the printer.

There was an error stating the printer could not be located.

I then stopped the print service again.

Copied back the spooler files from my temp directory and restarted the printer spooler service again.

I tested the printer and it appears to be working fine.

I suppose starting the printer spool service without the files in c:\windows\system32\spool clears the hiccup that was in the queue.

Collapse -

Thanks also!

by T_Mac In reply to Possible issue is a file ...

A file stuck in a queue was my issue also...very cool. I started the spooler from differently but no matter, same thing. Big problem, simple fix. Saved me from deleting drivers, etc. also. Thanks!

Back to Storage Forum
23 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums