Spooler Subsystem App has stopped working

By tintoman ·
I tried to install a network printer for my client on a Vista Home Premium laptop.
I got an error message saying that the spooler service was not running.
So I went to services.msc and started the service, however it stops almost immediately and the message is "an error" caused this - well hello?
I also noted that only "important" windows updates can be installed, those which are simply "recommended" consistently fail to install.
All input gratefully received as ever
Re-posted cus no one responded

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

did you try Microsoft Help and Support?

by CG IT In reply to Spooler Subsystem App has ...
Collapse -

Im obliged

by tintoman In reply to did you try Microsoft Hel ...

to you for your response but that article does not cover the problem I am having, as I said in my post all I get is a message saying "an error" caused the subspooler app to stop.
I need to find out what is likely to cause that and why this means that updates are not being installed
Thanks anyway

Collapse -

no real "likely" causes

by CG IT In reply to Im obliged

the print spooler service will not start if the computer the printer is connected to is turned off before all printing is completed.

you can't restart the spooler service, not print to the printer until you clear all pending documents.

As far as updates, sounds like someone tried to update the computer and decided to turn it off during the installation process. Updates can't be installed until a previous installation is completed.

Again, you can check Microsoft Help and Support under spooler service and there are many KB articles dealing with this and also check under update installation problems. Many many articles dealing with this.

oh btw this sounds like a tier 1 help desk interview question... like putting in a user name and password question on a laptop and the number lock key is on which makes letter keys numbers....

Collapse -

Have a look here

by Jacky Howe In reply to Spooler Subsystem App has ...

It may help sort the printer. I am still working on the updates.

Edit: I found this dont know if it will help but worth a try.

Stop service wuauserv.
Delete/Rename %windir%\SoftwareDistribution
Start service wuauserv.
Try the update again.

Collapse -

This is better...

by gomcse In reply to Have a look here

The following link had the answer for me:

The very first post on the first page is only half of the answer. The second page has a post at the top that is the second half of the answer, as it applied to my problem.

After doing both things (checking the LPR and LDR, and deleting the printers from the registry), my printers worked again.

I think this is a bigger issue. A second Notebook computer on my home network is now throwing the same error. I'm beginning to think there was an update by Microsoft that broke the spooler system.

Dave Hernandez.

Collapse -

Glad that

by Jacky Howe In reply to This is better...

you have sort of got it sorted.

Back to Windows Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums