SQL Server DLLs required on user's PC

By tim8w ·

I have deployed my program on several user's PCs and they get the following error I believe when the program tries to Open a connection: "Login filed for user". Kind of a strange error., since the credentials are in the program and I don't get the error when I run from my PC, but obviously I have all the correct DLLs installed since I have SQL Server 2014 installed on my development PC. What DLLs does the user's PC need to have installed? We are using SQL Server 2014.
Thread display: Collapse - | Expand +

All Answers

Collapse -

Fairly common issue.

by rproffitt Moderator In reply to SQL Server DLLs required ...

I recall the question back to many is "Is your SQL Server in 'mixed mode authentication'?"

Read for a common discussion and ideas on resolution.

Collapse -

Not the problem

by tim8w In reply to Fairly common issue.

Thanks for the suggestion, but that is not the problem. The .Net program is using a SQL Server authenticated user. It works on a PC that has SQL Server full version installed on it. It doesn't work on a PC that does not. Its that simple. All I need to know is what DLLs do I need to include on a PC that doesn't have full blown SQL Server 2014 installed

Collapse -

I take it

by rproffitt Moderator In reply to Not the problem

You are deploying with Visual Studio deployment wizard. Once in a while a developer will try to deploy by copying files around.

Anyhow, let's do a little research on SQL 2014 dlls.

Remember I can't know if your app is connecting to a bona fide Microsoft SQL Server or if you are running SQL Server on each PC. You have to reveal that soon as I will guess badly. And yes, I have written and deployed apps but we use MySQL in a central location.

1. if you are deploying SQL Server on each PC. I don't know what you mean by not full blown SQL Server since your first post, next post are pretty sparse.

2. where you work your Visual Studio settings to include SQL.

Collapse -

Integrated Security=SSPI;

by tim8w In reply to I take it

Actually ended up being this statement in my connection string. Once I removed that, it used the SQL Server user login I specified.

Collapse -

Thanks for the update.

by rproffitt Moderator In reply to Integrated Security=SSPI;

Sorry if I didn't help here. Just a designer/coder with some SQL implementations in corporate apps.

Related Discussions

Related Forums