SQL server running on XP SP2 problems

By minnarky ·
I have a timeclock application (SQL) running on an XP workstation connected to our domain that we can't connect to from any other machine on the network. It has been working perfectly for years, but now suddenly we can't connect.

Here is what I've tried:
enabled File and Printer Sharing in the Windows Firewall.
turned off the Windows Firewall.
checked for other firewalls.
removed machine from domain and re-added it.

Nothing seems to work.

Users can log on to the domain and everything is working in that respect. I can even connect to the SQL server from this machine and the application works, so I know SQL is working.
But I cannot even ping this machine from another one on the network. I can ping out, just not in.

Sure seems like a firewall, but there is not one here that I can find.

Any help would be greatly appreciated!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

if you cannot ping it....

by robo_dev In reply to SQL server running on XP ...

Physical layer issue: nic/cable/switch port

duplicate IP address?

If you run OSQL -L on the network, does the SQL instance show up in the list?

Collapse -


by minnarky In reply to if you cannot ping it....

The machine in question does show up with that command, along with many others.

We switched the cable and still no good, now we will try the switch port and the NIC.

Also, I am getting an error in the event logs about the domain can't register that ip number with the name...
but it isn't giving the netbios name of the pc in question, it is the domain name with a colon and some letters after. (That is why I removed it from the domain and re-added it. When I did that it worked for a few days and then quit again??)
There are no other machines with that ip number, we are using dhcp for the workstations, servers and printers are static.

Collapse -

Just a thought...

by cmiller5400 In reply to SQL server running on XP ...

Swap out the network cable. I have seen funny issues arise from a bad cable.

If there are no other firewalls installed as you stated, I would try uninstalling the NIC driver and then reinstalling the latest one. If that does not work, try another NIC card.

Collapse -


by minnarky In reply to SQL server running on XP ...

Thanks guys, I will check all the physical possibilities and let you know.

Collapse -

Resolved, I think

by minnarky In reply to SQL server running on XP ...

I replaced the cable, replaced the switch, replaced the NIC, all to no avail.

So I went back to my original assumption that something on this machine is blocking incoming SQL requests.

This machine has an AT&T VPN client installed, which was recently updated. Although there was no firewall running, there was an AT&T protocol filter attached to the NIC in the properties sheet. As soon as I unchecked that filter the timeclock application was accessible over the network again.

Related Discussions

Related Forums