General discussion

Locked

Squid

By MarktheB ·
I'm trying to set up a proxy server, but can't get squid to run. The error is pretty generic. Any suggestions?

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by mickey In reply to Squid

First, what is the "generic" error reported????
Without the error i can only guess the problem.

my quess
========
Squid is a funny duck. If you give squid a DNS name but there is no DNS it will usually stop.

If this is the case add a record in the /etc/hosts file. Also the /etc/HOSTNAME file is likely different or non existant.

Collapse -

by mickey In reply to Squid

First, what is the "generic" error reported????
Without the error i can only guess the problem.

my quess
========
Squid is a funny duck. If you give squid a DNS name but there is no DNS it will usually stop.

If this is the case add a record in the /etc/hosts file. Also the /etc/HOSTNAME file is likely different or non existant.

Collapse -

by mickey In reply to Squid

First, what is the "generic" error reported????
Without the error i can only guess the problem.

my quess
========
Squid is a funny duck. If you give squid a DNS name but there is no DNS it will usually stop.

If this is the case add a record in the /etc/hosts file. Also the /etc/HOSTNAME file is likely different or non existant.

Collapse -

by MarktheB In reply to Squid

I'll get details this weekend and post back ASAP.
Thanks,

Collapse -

by MarktheB In reply to Squid

The error that occurs on trying to start Squid is: Squid failed. The error was: Starting Squid:.........[Failed].
FYI I'm at RunLevel 5.

Collapse -

by MarktheB In reply to Squid

OK, the real errors are: localhost (squid): Could not find any nameservers. Please check your /etc/resolv.conf file or use the 'dns_nameservers' option in Squid.conf.
Child process 4342 exited due to signal 6.
Also: (squid): ipcache_init: DNS name lookup tests failed.

Collapse -

by MarktheB In reply to Squid

Judging by the errors you are right on both counts. Currently I am not an a network, but trying to get things in working order to use squid and a few other programs for an internet proxy server. So there is no DNS. How best do I resolve this. There is no HOSTNAME file and I'm not sure what you mean by adding a record. Forgive the ignorance, I am a complete newbie here.

Collapse -

by MarktheB In reply to Squid

Also, resolv.conf only has 'search localdomain' in it.

Collapse -

by debian In reply to Squid

check this link for configuration

www.debianhelp.co.uk/squid.htm

thanks

Collapse -

by thanetadmin In reply to Squid

Hi ,
1. Are you setting up Squid as Transparenet proxy ??
2. Do you use iptables with that for port forwarding??
3. what distro of Linux ??
4. what error you get on tail /var/log/squid/access.log ??

Please reply , i can help you ..

Kias

Back to Linux Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums