General discussion

Locked

ssh and priviledged ports

By ratherbfishing ·
Running ssh 1.2.30 on Caldera 2.3 LINUX. After I couldn't connect ssh through a new firewall, I discoverd it was attempting outbound connections at lower than ports 1024. SO far I have seen 1023 and 1022.

I have also been told by people that ssh does not use priviledged ports. Well it is on my system!

Can someone tell me if this is normal behavior? Is there a way to force it to use 1024 and up? and would I want to? I need the info so I can configure the firewall.

Thanks!

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

ssh and priviledged ports

by McKayTech In reply to ssh and priviledged ports

By default, the implementation of sshd that I use looks for incoming connections on tcp port 22.

Just to keep folks guessing, you might want to choose some other port for this, but I don't see any reason to mess with the high port range.

paul

Collapse -

ssh and priviledged ports

by ratherbfishing In reply to ssh and priviledged ports

Yes, ssh listens on port 22, but then negotiates a port to use with the client, supposedly 1024 or higher. However, for some reason it always wants to use 1023 or lower port on my system. I have seen in news lists a few other folks with this problem, but no clear answers so far.
Thanks for trying!

Collapse -

ssh and priviledged ports

by nobrega In reply to ssh and priviledged ports

Running ssh with the -p option will force it to run on non-privledged ports.

Collapse -

ssh and priviledged ports

by ratherbfishing In reply to ssh and priviledged ports

You are talkng about the port that the server listens on...the default is 22 which is fine. i am talking about the port that is negotiated to use after the initial connection is made. See answer to paul.
Thanks anyway!

Back to Security Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums