Question

Locked

SSH and Telnet not working (Vista)

By nsnoonan ·
I've had this computer for about 3 months now. I have been using putty to connect to various linux servers and networking equipment via ssh and telnet.

Recently, I haven't been able to connect to anything for about a week. I've checked logs to try to troubleshoot my issue, and they suggest the connections aren't even getting to the servers I'm trying to connect to. I've now tried several different programs all with the same result.

Putty's error is:
"network error: permission denied"

ssh from windows display's the following error:
"operation not permitted"

Poderosa's error:
"failed to connect to the port 22 on SERVER"

I've also tried uninstalling and reinstalling programs, google searches, disabling UAC, and random registry tooling, though I'm sure my ability in the registry isn't up to par for the task. I have no firewalls up, nor virus protection software that would cause anything like this.

I have a feeling it was caused by a few open source modification packages for putty I've recently tried out. Support for them are non-existent and I'm sure I can handle it via the registry, at the very least.

I've resulted to using a terminal server for any administration tasks that need ssh or telnet. I would really like not to have to wipe and reinstall if not entirely necessarily. This is my last resort before doing so.

Any help is much appreciated.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

You said...

by wanttocancel In reply to SSH and Telnet not workin ...

...that you have no firewalls up does that include the Windows Firewall? I would check to make sure that ports 22 (for ssh) and 23 (for telnet) are open and allowing incoming and outgoing traffic.

Collapse -

No windows firewall

by nsnoonan In reply to You said...

Yes, that does include windows firewall. No firewalls or protection programs (virus, spyware, adware, etc) are running, whatsoever.

Collapse -

More information

by nsnoonan In reply to SSH and Telnet not workin ...

Ok, after more tests, I've gotten some additional information. Here's what I've discovered:

* It's not user specific (profile-based). I've created users with varying security levels and all display the same results

* It's not driver based. I've uninstalled and reinstalled both with windows and the manufacturer's install package with the same results

* It's not network based. I've run wireshark captures on all interfaces and all telnet and SSH (among other protocols of which i can't name) don't even reach the interface, let alone get denied by the server

* I've tried a few other things that have had issues with network connectivity of which are not SSH or Telnet protocol based. Web-enabled applications like songbird (the browser inside) and Firefox 3.0.1 have no connectivity. The install package for the new google chrome will not complete, since it uses a connection of some type to install.

I will run more captures on those other applications to see what i can come up with. I'll also also probably run a hijackthis log or something...

Collapse -

Solved

by nsnoonan In reply to SSH and Telnet not workin ...

The problem has been solved.

As I said, it was as if there were a firewall installed (certain programs/protocols blocked, all new programs/protocols blocked).

I was checking through my installed programs and spotted Zone Alarm, of which I had thought I had uninstalled. I checked my startup programs, my services, and my currently running processes, all of which indicated Zone Alarm was not running. Just to be on the safe side, I went ahead and uninstalled Zone Alarm.

Everything works after uninstalling. I know that I had made absolutely no changes to Zone Alarm in quite some time, and I couldn't find it running anywhere. So at this time I would suggest others running Vista to either pay close attention to Zone Alarm if you chose to run it or not use it at all.

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums