Question

Locked

ssh is not connecting in SuSE10

By eldhom ·
Hi....
I am not able to connect to our SuSE10 - 64 bit machine via ssh. I tried to restart the service using "/etc/initd.d/sshd restart", it is failing without any error message.

To debug i did the following:

1. In the file /etc/init.d/sshd there is an option "start" . Under that there is a statement "startproc -f -f $SSHD_PIDFILE /usr/sbin/sshd $SSHD_OPTS -o "PidFile=$SSHD_PIDFILE"

I added echo $? and restart ssh. Now it failed with error 7.

2. I compared the binary files /usr/sbin/sshd of this machine and another machine [suse 10 64 bit] in which ssh is working. Both differ.

3. I tried to replace the following files from another system in which ssh is working.

/etc/ssh/sshd_config
/etc/init.d/sshd
/etc/pam.d/sshd
/usr/sbin/sshd

and then restarted ssh. Still the same error.

Kindly let me know how to fix this issue.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

well....

by ---TK--- In reply to ssh is not connecting in ...

error 7 is ERROR_SSH_UNSUPPORTED_CIPHER - There is no cipher supported by both: client and server.

I would suggest run at CLI "man ssh-keygen" and look at your options, it sounds like you might need a new authentication key for ssh...

Collapse -

One small detail

by robo_dev In reply to well....

if the binaries are different, just copying in replacement binaries may not work; there may be dependencies such as libraries that are also different.

Is this an internet-connected server? If your binaries have changed, I would look closely to see if a rootkit has been installed.

Back to Linux Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums