Question

  • Creator
    Topic
  • #4009945

    SSL_ERROR_ILLEGAL_PARAMETER_ALERT

    Locked

    by zersetzung ·

    After visiting youtube,076,ne,jp (an Invidious instance) literally 1,988 times (as per browser record) this year, I now get SSL_ERROR_ILLEGAL_PARAMETER_ALERT in my Firefox browser (v 107.0). I am the only one getting this error, no one else does. I know its a hack/purposeful harassment and I would like to know how to undo it? Im guessing some registry key was changed through the govt malware on my device.

    Found some answers on google, but I’m not changing my settings to allow no encryption (changing some settings in browser from 1 to 0 and so on)…besides I have a bit of a different issue…im not behind a proxy (AFAIK) and I am client-side. I’m in the security field so please feel free to give real answers that are actionable….im not here to quibble on details; but if you need extra tech info feel free to ask…

All Answers

  • Author
    Replies
    • #4009947
      Avatar photo

      So did you try Firefox’s Safe Mode?

      by rproffitt ·

      In reply to SSL_ERROR_ILLEGAL_PARAMETER_ALERT

      If the problem goes away it’s likely some add-on.

    • #4010005
      Avatar photo

      Reply To: SSL_ERROR_ILLEGAL_PARAMETER_ALERT

      by kees_b ·

      In reply to SSL_ERROR_ILLEGAL_PARAMETER_ALERT

      Does it happen also in Chrome or Edge? If not use that browser.

      Or make a new Firefox profile (after exporting your bookmarks). Just rename the Mozilla>Firefox folders in your Appdata>Local and Appdata>Roaming folder and Firefix will make a new default one.

      • This reply was modified 1 year, 6 months ago by Avatar photokees_b.
      • This reply was modified 1 year, 5 months ago by Avatar photokees_b.
    • #4013614

      Reply To: SSL_ERROR_ILLEGAL_PARAMETER_ALERT

      by Johnharper2020 ·

      In reply to SSL_ERROR_ILLEGAL_PARAMETER_ALERT

      Look into this issue more after being able to Paste URL as request option in burp.

      After that was successful was thinking want else can I do so I play around in burp had no issue using intruder, crawling, auditing and could render the webpage in the response area.

      Still could not get the webpage to load correctly, bypass the proxy connection webpage and burp worked.

      On my kali box I look at zap a version 10 which old but works to see if the same issue would happen, it did not. So I started to use different browsers with zap no issues. was thinking maybe a older version of burp will work I was right it work no issues.

      So here is the burp suite community 2021.8.2 version that work with website on all browsers and version above this one would not work.

      To get this to work outside the kali box on my windows machine, I had to useburpsuite_pro_windows-x64_v2021_9_1 with chromium browser. I could not get any newer version of burp to work.

    • #4064324

      Reply To: SSL_ERROR_ILLEGAL_PARAMETER_ALERT

      by jessicacsw788 ·

      In reply to SSL_ERROR_ILLEGAL_PARAMETER_ALERT

      You should try with older version of Firefox. Sometime using older version will fix the issue. This is clear problem of compatibility. You should try older version of Mozilla Firefox.

      • #4130863

        Reply To: SSL_ERROR_ILLEGAL_PARAMETER_ALERT

        by hollyelwirawinnie ·

        In reply to Reply To: SSL_ERROR_ILLEGAL_PARAMETER_ALERT

        I try and it doesn’t work

      • #4203027

        Reply To: SSL_ERROR_ILLEGAL_PARAMETER_ALERT

        by starone034 ·

        In reply to Reply To: SSL_ERROR_ILLEGAL_PARAMETER_ALERT

        I understand your concern about the SSL_ERROR_ILLEGAL_PARAMETER_ALERT you’re encountering on your Firefox browser. Here are some steps you can take to troubleshoot this issue:

        Check Browser Settings:
        Ensure that your browser settings haven’t been altered unintentionally. Reset your Firefox settings to default by going to about:preferences#privacy in your address bar and clicking on “Restore Defaults” under the “Privacy & Security” section.

        Clear Browser Cache and Cookies:
        Clear your browser cache and cookies as corrupt data might be causing the SSL error. Go to about:preferences#privacy and click on “Clear Data” under the “Cookies and Site Data” section.

        Update Firefox:
        Ensure your Firefox browser is up-to-date. Sometimes, older versions might have vulnerabilities or bugs that can cause SSL-related issues.

        Disable Firefox Extensions:
        Temporarily disable all extensions in Firefox to see if any of them are causing conflicts. Navigate to about:addons and disable all extensions. Then, try accessing the site again.

        Antivirus and Firewall Check:
        Run a thorough scan using a reputable antivirus software to check for malware or any potential threats on your device. Also, check your firewall settings to ensure they’re not causing the SSL error.

        Reset Network Settings:
        Sometimes network settings can cause SSL errors. Reset your network settings by going to about:preferences#general and scrolling down to “Network Settings.” Click on “Settings” and choose “Reset to Default.”

        Contact System Administrator or ISP:
        If you suspect any interference from the government or your ISP, consider contacting your system administrator or ISP’s support to verify if there are any restrictions or configurations on your network causing this issue.

        Check System Hosts File:
        Malicious changes to the hosts file can redirect traffic. Verify the hosts file on your system (usually located at C:\Windows\System32\drivers\etc\hosts on Windows or /etc/hosts on Linux) to ensure there are no unauthorized entries.

        Try Accessing the Site from Another Device or Network:
        Attempt to access the site from a different device or network to determine if the issue is specific to your device or network.

        Note: spam link removed by moderator.

        • This reply was modified 5 months, 1 week ago by starone034.
        • This reply was modified 5 months, 1 week ago by Avatar photokees_b.
    • #4130862

      Reply To: SSL_ERROR_ILLEGAL_PARAMETER_ALERT

      by hollyelwirawinnie ·

      In reply to SSL_ERROR_ILLEGAL_PARAMETER_ALERT

      I also get this trouble.

Viewing 4 reply threads