Question

Locked

Stop XP from asking which OS to load

By gary_florian ·
I tried to reinstall XP Pro on a Dell Inspiron 1501 laptop that was already running XP Pro, service pack 3. The reload failed. I subsequently was able to resolve all of the issues on the Dell, so in reality the reinstall was not necessary. Problem, during the boot process I am prompted to select which OS I want to load. It always defaults to the OS that failed to load. How do I deletethe failed OS entry on start-up?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Deselect duel booting in Windows XP

Windows XP includes support for multiple partitions and multiple operating systems (it inherits this ability from Windows NT/2000). The boot program (NTLDR) is stored in the root folder of the first partition on the first disk. NTLDR reads the Boot.ini file, which is stored in the same folder, to find out which partitions you might want to boot from, which partition to use as the default, what to display in the boot menu, and how long to wait before loading the operating system from the default partition. If the boot menu contains only one option, you won't see it, NNTLDR simply boots from that partition.

NTLDR and Boot.ini are hidden or protected system files. If you want to see them in an Explorer window you need to, choose Tools > Folder Options > click the View tab, and deselect the Hide Protected Operating System Files check box. Also choose Show Hidden Files and Folders.

Edit Boot.ini:
You can edit the Boot.ini file by using one of three Windows programs: The System Properties dialog box, the System Configuration Utility (displays the whole file for editing), or Notepad.

Hope this helps you.

Collapse -

Try this

by Jacky Howe In reply to Stop XP from asking which ...

Press the Winkey + Pause/Break, select Advanced. Under Startup and Recovery select Settings. Select Edit and you can remove everything but this.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

Tip. Copy and Paste this over the contents of the boot.ini and then Save the file. Restart the System.

Back to Laptops Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums