Hardware

Question

Stuck at press F2 or Del

By anthonym1992 ·
Tags: Hardware
Hi guys
I have just built my first PC but have run into an issue where I get to the first screen which says press f2 or del but pressing these keys does nothing. It is an Asus b550-f motherboard, ryzen 5 5600 CPU, g skill 32 GB ram, 850w PSU and an rtx 3080. In trying to fix this issue I have found the following:
The screen does not display at all if I remove the GPU and plug display port/HDMI directly to the motherboard and turn on the pc. It does display the press f2/del screen if I instead put HDMI into the GPU.
Both keyboards I've tried work on my old PC.
The computer turns on, everything lights up and the fans spin including the CPU fan.
The keyboard lights up but pressing f2/del has no effect.
I tried having only one stick of ram but this did nothing.
I inspected the CPU and as far as I can tell no pins are bent.
I have checked all the small panel cords are correct and the CPU 8 pin power is connected to the mb.
Could this be an issue with the motherboard outputs given keys on keyboard plugged into the rear USB ports aren't working and display output from motherboard isn't working?
Many thanks for your help!
Thread display: Collapse - | Expand +

All Answers

Collapse -

Let's cover the onboard video first.

by rproffitt Moderator In reply to Stuck at press F2 or Del

To use that you need the AMD APU (it has the graphics on the CPU) so what you noted there is proper for the https://www.amd.com/en/products/cpu/amd-ryzen-5-5600x CPU you listed.

With that out of the way the most COMMON GAFFE I encounter is the PC builder shorted out the motherboard with too many standoffs.

Try a much smaller build. NO CASE. Put the motherboard and parts on cardboard (no drives needed yet) and see if you can get to the BIOS. With a cardboard build (many times written up on many discussions) if that fails you ask the motherboard maker in their forum for new ideas such as a CMOS reset etc.

Collapse -

A few years ago this was often caused because you

by OH Smeg Moderator In reply to Stuck at press F2 or Del

Where using a USB Keyboard when you had a PS2 connector on the M'Board. Yes I know your M'Board doesn't have PS2 Mouse and Keyboard connectors so what you have to do is use the Primary USB Connector to plug the keyboard into not just any USB Socket.

You also have to plug directly into a M'Board USB Socket not one on a Fly lead or through a Hub it has to be one directly on the M'Board so this generally means one on the Back Panel and the one that the M'Board Manual shows as Primary or 1. Also plug the mouse into the next USB Socket 2 or whatever ASUS say in the manual.

Sure I know it's going to work on any USB Socket once the OS is running but for the initial Setup and OS install the Keyboard and Mouse need to be plugged into the primary USB Sockets.

Also remember no Wireless Mice or Keyboards as the necessary drivers are not installed that early in the boot process.

Collapse -

Vote for rprofittt

by mobuysellram In reply to Stuck at press F2 or Del

He hit it on the nail- try a smaller build first. No case is key.
(Edited by Moderator)

Related Discussions

Related Forums