General discussion

Locked

Sun Blade 100 boot failure

By ianATonlineloop.NOcom ·
Hi all,

My Blade 100 is currently not booting giving the
error:

Boot Device: disk File and Args:
Boot load failed.
The file just loaded deos not appear to be
executable.

I have set autoboot to false and have OpenBoot
4.0 available. Diagnostics indicate the machine
is OK. Booting from CDROM (boot cdrom) fails too.

I've scratched around everywhere but have so far
come up empty handed. Does anyone have any idea
how I can get this machine back up again?

Ian

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by platformrogue In reply to Sun Blade 100 boot failur ...

The Sparcs I've worked on in the past have always had a probe-scsi command to probe the scsi bus. That said I have no experience with the Sun Blade systems and don't know if they have a similar command.

Hope this helps.

Tom

Collapse -

by ianATonlineloop.NOcom In reply to

Poster rated this answer.

Collapse -

by mrw In reply to Sun Blade 100 boot failur ...

Hi Ian,

Try reseting autoboot? to true, as are my sunblade's. Next make sure your disk is spinning up. probe-scsi should work, as Solaris sees the disks as scsi wether they are or not. Good luck.

Collapse -

by ianATonlineloop.NOcom In reply to

Having autoboot true doesn't help. The system locks in
openboot with the message "Boot Device: disk File and Args:",
nothing else. The disk is also ok. In a linux system, I was
able to do a nondestructive check of the hdd and there were
no errors reported. The file on the partitions were also
readable, so I have no reason to believe there is any kind of
physical problem with the hdd. Probe-scsi in OpeBoot did not
return any found devices. Probe-ide found both hdd's and the
cdrom.

Collapse -

I was able to solve the problem, but it seems I
can't close the question. Sorry, but I will have
to reject any further answers.

It seems the problem was in OpenBoot taking on
its default values instead of those previously
set. That put the machine into an unbootable
state. Fixing that problem solved it.

Collapse -

This question was closed by the author

Back to Linux Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums