General discussion

Locked

Suse10 domain users not visible in Win2k

By dwadejr ·
I have a SuSE v10.0 primary domain controller and several Windows 2000 clients. I am able to add the win2k client computers to the domain with no problem, but when I try to add the users (which are already added to Samba on the server) I get a message saying that user doesn't exist. When I click "browse" to see a list of user accounts available only "root" and "nobody" with a white x in a red circle over it shows up. any ideas why my users aren't showing up?? I am VERY new to Linux, so any help is appreciated.

I was told to add them as local users on the linux machine. when i tried to add them using useradd, the computer told me they already existed. how can I make my windows clients see the users ?

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by dwadejr In reply to Suse10 domain users not v ...

Point value changed by question poster.

Collapse -

by Nico Baggus In reply to Suse10 domain users not v ...

I think you also have to add them to the samba
password file (you dont tell you allready did
that).

You will need that if encrypted passwords are
used.
so: smbpasswd -a <user>

the user MUST exist in the /etc/passwd file
before this.
See also man smbpasswd.

Collapse -

by dwadejr In reply to

The users have already been added to Samba, but when I try to add them to linux itself, I get an error saying they already exist. Is there some way of adding the user just to Linux in order to see them across the network that I'm missing?

Collapse -

by dwadejr In reply to Suse10 domain users not v ...

The users have already been added to Samba, but when I try to add them to linux itself, I get an error saying they already exist. Is there some way of adding the user just to Linux in order to see them across the network that I'm missing?

Collapse -

by Nico Baggus In reply to Suse10 domain users not v ...

What setup are you using....

There is much more information needed here...
are you using /etc/passwd + shadow
are you using ldap?

Did you enable the users using the smbpasswd?

I hope this might give some mor clues where to
look...

Collapse -

by dwadejr In reply to

I'm really very new to Linux, but I used the SuSE v 10 graphical interface to set this up, I didn't actually use the command line--the only time I used the command line was when I couldn't find any other way to add a user to the system itself and I tried the useradd command, but it said the user was already there. I added the users and their passwords in Samba from within the SuSE gui. I don't know if this helps but when I boot up at the login screen it only shows my user id and root. I'm really new to this so if you need more info, please let me know.

Collapse -

by Nico Baggus In reply to Suse10 domain users not v ...

OK the logon screen is from X, you need to
configure users separate from samba of linux.
You need to tell the XDM/KDM manager what users
should be shown. Different story.

Please logon, and from the command line check if
users are in the passwd file and or samba files
with:

grep
"username" /etc/passwd /etc/samba/smbpasswd

(all on one line).
I am not 100% sure that /etc/samba/smbpasswd is
the exact correct path. the file you're looking
for is at least called smbpasswd.

Local users are in /etc/passwd samba users in
smbpasswd.

If the usernames are in both files we have to
look further in samba configs, just check this
for now.

Collapse -

by dwadejr In reply to

That was the problem. Once I added the user to smbpasswd from the command line it worked fine. Thank you VERY much... I've spent weeks on this problem. Enjoy your 750 points... this answer was worth every one!!!

Collapse -

by dwadejr In reply to Suse10 domain users not v ...

This question was closed by the author

Back to Linux Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums